3 Replies Latest reply on Aug 25, 2019 11:55 PM by GauravS_31

    OTA update for DCT image

    RaBa_4156341

      Hi Team,

       

      I am working on wiced sdk 6.2.1 in FREE RTOS platform. In this free rtos platform OTA2 is not supported, so i am using OTA.

       

      First I tried writing APP binary into DCT_APP1_INDEX of external flash (chunks of 1024 bytes received from socket) and able to boot properly from this location when you reboot.

       

      In similar way tried to write DCT binary into DCT_DCT_IMAGE_INDEX of external flash. It is able to write but when you reboot it was not effecting that changes.(not booting)

      Actually when you update DCT and reboot that changes should reflect in app.

       

      what is exact location to write DCT binary for OTA?

       

      Is there anything to change in lookup table when you update only DCT?

       

       

      Thanks,

      Raviteja.

        • 1. Re: OTA update for DCT image
          GauravS_31

          The OTA update happens inside function process_upgrade_chunk() at wiced_framework_app_open( DCT_APP0_INDEX, &app ) in libraries/daemons/ota_server/wiced_ota_server.c. The OTA implementation allows update of only application (APP0) and not DCT or any other memory blocks. Can you consider using ThreadX for OTA2?

          • 2. Re: OTA update for DCT image
            RaBa_4156341

            Thanks for quick response,

             

            For our project we have to use FREE RTOS platform, so we can't use Threadx.

            we were able to update app using above mentioned function, but for DCT it was not happening.

            Is there any other way to update DCT using OTA?

            These are indexes available for OTA. For app 3 indexes available.

             

            DCT_FR_APP_INDEX         

            DCT_DCT_IMAGE_INDEX      

            DCT_OTA_APP_INDEX          

            DCT_FILESYSTEM_IMAGE_INDEX 

            DCT_WIFI_FIRMWARE_INDEX    

            DCT_APP0_INDEX            

            DCT_APP1_INDEX         

            DCT_APP2_INDEX       

             

            Why only one index for DCT?

            Can we create new index for DCT here? If possible how we can create?

            please give your inputs for DCT update using FREE RTOS?

            • 3. Re: OTA update for DCT image
              GauravS_31

              As stated earlier, DCT update is not supported in OTA implementation. And DCT_IMAGE is meant for internal usage which is why there is only one index for DCT unlike APP0 which is free for users. You can check this thread SDK 6.2 OTA2 image build error: Illegal division by zero at ./tools/text_to_c/sector_count.pl  where OTA2 was working with freertos.