10 Replies Latest reply on Aug 5, 2019 5:30 AM by GeJo_4320246

    Can't find my error with emFile after tried multiple solutions

    GeJo_4320246

      Hi everyone,

       

      As I said in the title, I just can't figure out what's wrong with emFile. This is for my master thesis and I don't have a lot of time left...

       

      Here what I use in this project :

      • 'PSoC 5LP CY8C5888LT*-LP097' Prototyping kit
      • 2Go Micro SD transcend card
      • microSD click from Mikroe
      • SD Card Formatter and/or Formatter from Windows 10
      • UART (named UARTGPS because of my project) communication with Termite 3.4  instead of LCD in the example.
      • Default configuration for emFile in TopDesign

       

      I followed every step for the installation (in build settings, etc).

       

      The example provided just does won't build : "Build error: MMC_X_HW.h: No such file or directory" is the error message and I can't figure out why.

       

      I also tried on my own workspace for my master thesis (it is supposed to be coupled with GPS and UMTS modules but I tried to hide that part in the attachment since it is not related to the problem. In my workspace I don't have any error displayed during the build but it just seems that it can't see my micro SD card. I changed the SD Card to "UMTS" and still, it displays "mmc:0" as name then fails for each action in the example.

       

      I  tried (on my code, not the example)  the pins P2[3:6] which I believe is not linked to any problematic hardware like bypass capacitors. Then tried with pins 12.2 12.3 12.4 12.0, same result.

       

      What I don't understand is why it doesn't find "MMC_X_HW.h" in the example but does in the my project.

       

      As you can understand I am very confused and struggling because of that problem and I really need help (which I don't do that much, this is my first time posting on a forum but I am desperate right now).

       

      Thank you in advance for all the help you can provide !

       

      Sincerely yours.