5 Replies Latest reply on Jul 26, 2019 3:26 AM by GeIo_1586191

    Problem updating to BT SDK 1.3

    GeIo_1586191

      I followed these instructions: ModusToolbox BT SDK 1.3

       

      But got this error:

       

      UpdateError.png

       

      Please help.

        • 1. Re: Problem updating to BT SDK 1.3
          GeIo_1586191

          It appears that I had just uninstalled SDKs 'Cypress SDK[1.1.0.940], bt_20819A1[1.0.0.940]'.

           

          The question now is where the heck do I now find these SDK's to reinstall.

          • 2. Re: Problem updating to BT SDK 1.3
            GeIo_1586191

            Right, I had to do a complete uninstall and reinstall to work out what went wrong.

             

            So, it appears that this dialog box is rather misleading.

            UpdateSDKs.png

             

            Nowhere does it state on the dialog box that those SDK's are the ones already installed.

             

            As it is an Update ModusToolbox dialog box, believe it or not, but I took it that those were SDK's listed to be updated and you ticked to box to update (I did not test clicking on the Remove or Bin icon, which is a pretty standard GUI process to delete stuff).

             

            As a suggestion, maybe for dumb folk like me say "tick to Remove" and this would be clearer.

            • 3. Re: Problem updating to BT SDK 1.3
              MichaelF_56

              ModusToolBox 1.1 with the initial BT_20819A1 SDK is here: ModusToolbox BT_20819A1 SDK

               

              BT_SDK 1.2 is here: ModusToolbox BT SDK 1.2 

               

              Someone from the Applications team will need to respond regarding the error that you are seeing.

              • 4. Re: Problem updating to BT SDK 1.3
                DheerajP_41

                Hi Gerriko IoT,

                 

                Two default packages come along with Modus1.1. One is 'PSoC6 SDK' and other one is 'BT 20819A1 SDK'. If you want to upgrade the application package of 20819, please uninstall 'BT 20819A1 SDK' and install 'BT SDK1.3' (latest package for 20819) from ModusToolbox BT SDK 1.3  . (please download the attachment and install it as per the given instruction)

                To uninstall an existing SDK, you have to tick on check box of the SDK and click 'OK'. You will be able to the status in the modus console window.

                To install an SDK you have to select the required SDK file from your computer by clicking 'Install Custom SDK' and Click OK. You will be able to the status in the modus console window.

                 

                When did you get this error message (attached pic in your question)? Did you uninstall both the default SDKs? We will try to reproduce this error at our side and will check whether it is an expected error or not.

                 

                "As a suggestion, maybe for folk like me say "tick to Remove" and this would be clearer." -> Thanks for your suggestion. I agree with you. 

                 

                Thanks,

                -Dheeraj

                2 of 2 people found this helpful
                • 5. Re: Problem updating to BT SDK 1.3
                  GeIo_1586191

                  Thank you for your response. Very helpful.