2 Replies Latest reply on Jul 26, 2019 2:15 PM by JoLo_1693126

    Cysmart - Starting from Android 6.0...

    JoLo_1693126

      Hello,

      I downloaded Cysmart for Android. When I start the app I get the following message:  "Starting from Android 6.0 Marshmallow the system requires location permission in order to scan Bluetooth LE devices.  Bluetooth beacons, like iBeacons or ........"

       

      It gives me the option "ok" and "cancel". When I press Ok, the app shuts down.  When I press cancel, then click on "BLE devices" from the drop down menu, the same message appears.

       

      Any help would be appreciated. Yes, I turned on location on my cell.

       

      Joseph

        • 1. Re: Cysmart - Starting from Android 6.0...
          DheerajK_81

          Hello Joseph,

           

          Please go to the settings of CySmart app. It should be in your installed apps under Settings. Under Permissions, check if you have enabled location and storage permissions for the app.

           

          Then run the app. It should work.

           

          If both are already enabled and you are still seeing the issue, please provide us information on the Phone, Android version and Cysmart app version you are using.

           

          Android Studio can be used to generate logs using Logcat window. If you have experience using this IDE, please connect the USB to your phone and run the app. The Logcat window will report the logs. Please copy the logs into a file and attach it here. It will provide us clear information on the error.

           

          Regards,
          Dheeraj

          • 2. Re: Cysmart - Starting from Android 6.0...
            JoLo_1693126

            Thank you Dheeraj!