4 Replies Latest reply on Jul 23, 2019 2:12 AM by DheerajK_81

    PSoC 6 Pioneer Kit, ModusToolbox, KitProg3, Blinky demo not blinking

    RiKw_4278376

      I have a new PSoC 6 BLE Pioneer Kit (CY8CKIT-062-BLE) that I'm trying to bring up with ModusToolbox 1.1.0 (Build ID: 234) on a macOS system.  This is actually my second board; I successfully brought up the first Pioneer board on this macOS system, and have done some development with it.  (Alas, I've relinquished my first board to my hardware-modifying co-workers.) In bringing up this second board, I realized it wasn't talking, upgraded it from KitProg2 to KitProg3, still didn't talk, and decided to run the blinking LED demo. Alas, it still isn't talking. What it is doing is "pulsing" or "breathing" on LED2 (yellow LED below SW3) on about a 1-second cycle; it feels like a PWM demo, which I didn't install.

       

      To confirm that the board is talking to KitProg3, I run 'bin/fw-loader --device-list'. The command reports back,

       

      Cypress Firmware Updater, Version: 2.1.0.52

      ...

      Info: Connected - KitProg3 CMSIS-DAP HID-1C1417B0XXXXXXXX

      Info: Hardware initialization complete (473 ms)

      Connected supported devices:

              1: KitProg3 CMSIS-DAP HID-1C1417B0XXXXXXXX FW Version 1.10.2946

       

      (I don't know if obfuscating the device address was necessary here, but I saw someone else do it, and more so.)

       

      On opening the configurator, I've confirmed that pin P0[3] is named "LED_RED", which corresponds to the CY8CKIT-062-BLE Kit Guide.

       

      When I launch the code using "Debug (KitProg3)", LED3 (Green) flashes as the code is downloaded. However, the IDE buttons do not show that I can step into or over any code (normally keys F5 and F6); the corresponding buttons are greyed out. Furthermore, the window (pane?) for the thread indicates that there is no debug info available.

      mt-blinky-debug-nostep.png

      Yet, when the code was built, I can see flags "-0g", "-g3", and "-g" passed to GCC.

       

      Alternatively, I've tried building the Release version. I see these flags passed to GCC: "-Os", "-g".  Launching with "Debug (KitProg3)" looks like what happens when the Debug version is launched. Launching with "Program (KitProg3)", is similar but reports:

       

      ** Programming Finished **

      ** Program operation completed successfully **

      srst_only separate srst_gates_jtag srst_open_drain connect_deassert_srst

      Info : SWD DPIDR 0x6ba02477

      shutdown command invoked

       

      To my untrained eye, this looks fine.  And yet, the blinky demo is not operating. Instead, the pulsing of LED2 is still active.

       

      So now, I am completely stuck... Halp!