1 Reply Latest reply on Jul 9, 2019 12:06 AM by PradiptaB_11

    FM25V01A: follow up to the now locked https://community.cypress.com/message/183373#183373

    AlPa_3955366

      This is a follow up to:

      https://community.cypress.com/message/183373#183373

       

      That discussion is locked now, no doubt because I disappeared. I'm back to being able to work on the problem again.

       

      In that discussion, I told of my trouibles: I tried moving from the 64Kbit version to the 128Kbit version (FM25V01A) of the Cypress FRAM. I got no response from the FM25V01A, even though the SPI interface and the code I've written are essentially the same for both.


      One suggestion was to read the ID or status register, but of course since there is no response on MISO, the problem remains.

       

      Another suggestion was to show the power ramp up; the minimum according to the datasheet is 50 us/V. So, on 3.3V, I need at least 165 us. The attached image shows the analyzer's view of about 0.659 ms. Should be enough. Still no response on MISO.

       

      Any other ideas for troubleshooting?

       

      Thanks.