1 Reply Latest reply on Jun 29, 2019 11:02 AM by DheerajK_81

    Creating uVision Projects for PSoC 6 and Problem with SysTick Interrupt

    CoreyW_81

      I am trying to use Keil uVision to debug a PSoC project by following the help topic "Create uVision Projects for PSoC 6".

       

      The project was built and debugged in PSoC Creator and it worked perfectly on the board. But if I try to build the same project by exporting to uVision, it can only be debugged partially and failed to enter interrupt, and accordingly the code will not work on the board.

       

      In details, I have chosen the ARM MDK Compiler in Build Settings, and export it as a PACK to be included in the uVision project. The project compiled successfully but somehow it didn't enter the interrupt that I set for SysTick (initialized by systick_set_call_back() function). I set a breakpoint in the callback function and I could see from the debugger that COUNTERFLAG has been set for systick (which means it reaches zero and round over) and that ISR number in xPSR is 3 which is HARD FAULT, while it should be 15 for SysTick, and the program never entered the callback function.

       

      Alternatively, if I tried to use GCC to compile my PSoC project and export it to Keil uVision, the startup file would fail to compile.

       

      Do you know any open issue on this? We can send you both PSoC and uVision project if you need. Thank you!