2 Replies Latest reply on Jun 24, 2019 4:18 AM by pasac_4169811

    Cant enter Deep Sleep

    pasac_4169811

      Hi,

       

      so I am trying to implement the deep sleep function into the "dynamic broadcaster projekt" which I modified.

      I think I implemented the deepsleep function as recommended but I somehow cant figure out why it is not working.

       

      I checkt the power consumption with a oscillator and got about 2,2mA which is okay for sleep but not deepsleep so my conclusing was that the System is not entering deep sleep.

      I disable the Debugging Option to safe some power.

       

      I am using the CY224116 Chip in combination with the CY8CKIT-042-BLE.

       

      I guess something is keeping the BLESS awake but I dont know what.

       

      I hope someone can help me

        • 1. Re: Cant enter Deep Sleep
          PY_21

          Hello,

           

          1. Please change the Debug select from SWD to GPIO (if Debug is not needed). In Design Wide Resources Go to "system" view and change "Debug Select" to GPIO.

          2. Also, if you don't want to use the GPIO pins whole time, you can put the pin drive mode into Analog High Z using APIs Pin_SetDriveMode(Pin_DM_ALG_HIZ) before entering into Deepsleep. And can switch back to normal drive mode when pins are used. Please refer the section 6.3 GPIOs of AN86233.

          In your project, WDT or BLESS will wakeup the system from Deepsleep. BLESS will wake up every advertising interval and this will wake up the MCU from Deepsleep. To get more details on using BLE and low power modes please go through AN92584 application note.

           

          Thanks,

          P Yugandhar.

          • 2. Re: Cant enter Deep Sleep
            pasac_4169811

            First of all I want to thank you P Yugandhar for your Response.

             

            Regarding 1. Thanks pointing it out, it cut the current consumption in half. Very nice.

             

            Regarding 2. The GPIO Pins were a left overs of the example Project so those got deleted. Again thanks for pointing it out.

             

            Now for the Problem it self, I tried calculating the current consumption via a Oscilloscope by measuring the voltage at a known resistor.

            Which worked fine for the aktiv and sleep mode since the cosume more than 1 mA which btw is the Limit of the Oscilloscope I am using.

            You my notice the Problem there. So I switched to a Digitale Multimeter which can measure nA and for my relieve I could see that the Chip is entering into the deep sleep mode as wanted.

             

            TL,DR Wrong type of measurement Equipment.