5 Replies Latest reply on Jun 12, 2019 4:22 AM by StSi_1143416

    Problems running BLE Mesh LightDimmable example

    StSi_1143416

      Hi I am new to Modus Toolbox and Eclipse, so possibly my problem has a very easy solution. I have installed Modus Toolbox 1.1 and the Modus Toolbox BT SDK1.2 and have started to go through the "How to design with Bluetooth Mesh" video. However when I try to build and program the BLE Mesh LightDimmable example I get the following error:

       

      Download file D:/Users/Stephen/mtw/BLE_Mesh_LightDimmable_mainapp/Debug/mainapp_download.hex not found, aborting download!

      Try to clean and rebuild all

      Download failed

       

      I have tried the clean and rebuild and get the following error:

       

      D:/Users/Stephen/ModusToolbox_1.1/tools/wiced-scripts-1.0/bt_post_build.bash: line 238: D:/Users/Stephen/ModusToolbox_1.1/tools/wiced-tools-1.0/BT/CGS/bin/cgs: No such file or directory

      make[2]: [post-build] Error 1 (ignored)

       

      I have tried installing Modus and the SDK on both my desktop (running Windows 7 64 bit), and my laptop (running Windows 10) and get the exact same error.

       

      So far my introduction to Modus and Eclipse has been very frustrating so any help would be greatly appreciated!

        • 1. Re: Problems running BLE Mesh LightDimmable example
          StSi_1143416

          I have done the following:

          1. Opened build settings

          2. Selected Create Flash Images in the Toolchains page and then pressed apply

          3. In the Tool settings page when GNU ARM Cross Create Flash Image is selected, I have entered the following line into export settings,

          ${COMMAND} -O ihex ${ProjName}.elf mainapp_download.hex then pressed apply and close.

           

          Modus now finds the hex file but now produces the following error:

          cant open D:/Users/Stephen/mtw/BLE_Mesh_LightDimmable_mainapp/Debug/mainapp_hci_id.txt at D:/Users/Stephen/ModusToolbox_1.1/tools/wiced-scripts-1.0/ChipLoad.pl line 71.

          This is because there is no mainapp_hci_id.txt file in the project directory. So my questions are as follows.

           

          1. Am I doing the correct thing by entering the command as in step 3 above? If not what is the correct procedure to produce a hex file?

          2. Why am I now getting an error that Modus cannot find the mainapp_hci_id.txt, or more appropriately put, why is there no mainapp_hci_id.txt in the project directory?

          3. Surely all of the above should be automatic as I am trying to run a Cypress example?

          • 2. Re: Problems running BLE Mesh LightDimmable example
            MichaelF_56

            Adding several members of the Cypress Applications team that support our BT/BLE products: SheetalJ_96, RaktimR_11, XinghaoZ_26, AnjanaM_61, PriyaM_16, ZhengbaoZ_96

            • 3. Re: Problems running BLE Mesh LightDimmable example
              SheetalJ_96

              Hi StSi_1143416,

               

              I was able to download the program properly following the instructions in Video.

              Can you once try uninstalling the MTB1.1, then delete all the related previous files at the install directory and re-install? You dont have to change any Build settings.

              1 of 1 people found this helpful
              • 4. Re: Problems running BLE Mesh LightDimmable example
                StSi_1143416

                Hi everyone, ok I have found the cause, my antivirus package (Vipre) is finding a virus in MTB1.1 when running the example. It then quarantines the virus (this may or may not be a real virus), this quarantining action must be damaging something in MTB1.1 which prevents MTB1.1 from creating a hex file. The only way I can successfully run and build the examples is to switch off my antivirus package re-install MTB1.1 and reload the SDK. However the moment I switch on my antivirus and try to rerun the examples, it doesn't work again. Note that it is not sufficient to delete the mtw folder or to unload and then reload the SDK, I have to re-install everything.

                 

                I am not sure what the fix should be, could there be a virus in MTB1.1 or is my virus package identifying something that MTB does as being malicious? I can operate on a short term basis with my antivirus off, but this is not a long term solution.Virus1.jpgVirus2.jpg

                1 of 1 people found this helpful
                • 5. Re: Problems running BLE Mesh LightDimmable example
                  StSi_1143416

                  Hi Sheetal, thank you for your help. I have replied in the community

                  that there seems to either be a virus in the MTB1.1 or my antivirus

                  package picks up something that looks suspicious when the MTB runs the

                  examples. Note that this happens when actually running examples and not

                  during the installation process (I switch off my virus programmes when

                  installing) . It may be worthwhile for Cypress to check the MTB and SDK

                  for any viruses?

                   

                   

                  Best Regards

                   

                  Stephen