3 Replies Latest reply on May 12, 2019 1:40 AM by FaBi_2763241

    BLE OTA android app issue

    FaBi_2763241

      Hello,

       

      while previously the OTA process using the Cysmart android app was working okay now I am facing with an issue that the progress is stuck at 0%.

      The thing puzzling is that I am using the same unchanged project which has been tested working always fine, it still gets the OTA process completed successfully using the cysmart dongle on pc.

      It used to work also with the app but with a different phone which I no longer have. I am trying with two different devices running os 4.4 and os 8.1 both unsuccessfully.

      Firmware and app have the same unchanged code which were tested okay, that makes me think it might be a phone or android issue.

      I have attached the log from the cysmart app, there aren't errors but it doesn't transfer the image.

       

      Regards

      Fausto

        • 1. Re: BLE OTA android app issue
          DheerajK_81

          As seen from the release notes, the app will need to have Android 5.1.1 or higher for better working. So, Android 4.4 Device might fail. About Android 8.1, can you give us more details on which phone you are using. I do not know about the modifications you have made to the app. So, can you try to reproduce the issue with Cysmart Source Code?

           

          Please connect the phone to Android Studio and run the OTA process. Share the logs present in the Logcat window.

           

          Release notes can be found here: https://www.cypress.com/file/198626/download

           

          Regards,

          Dheeraj

          • 2. Re: BLE OTA android app issue
            FaBi_2763241

            Hello

             

            the phone is Motorola E5 Play with os 8.1.

            I have tried in this phone today both Cysmart app, the official apk and the source built in android studio 3.3.

            The one from google playstore works, and the one compiled from source works only with target no over sdk 25, if 26 or over the problem of OTA not writing will happen.

            No code was modified. The gradle is 3.0.1 and build tools v26.0.2.

            Now google requires to target at least sdk 26 for app to distribute; to overcome this problem, can one request the newer source code for the OTA section of cysmart from cypress?

            I think the source available from cypress website is still the same targeting sdk 22.

             

            Fausto

            • 3. Re: BLE OTA android app issue
              FaBi_2763241

              I see now there is the updated cysmart 1.2.0.256 source with minimum sdk 22 available, I was still running the cysmart 1.1.1.68 which caused my issue.

               

              Regards

              Fausto