10 Replies Latest reply on Jun 27, 2019 4:26 AM by KandlaguntaR_36

    OV7251 show blackscreen with USB2.0

    soqi_4187516

           I am developing ov7251 (raw10, vga, 30fps) with usb2.0, maybe there is someting wrong in the sequence, the screen is black. But usb3.0 is ok.

       

           It looks abnormal in the log:

       

      OV7251 Camera CyCx3_ImageSensor_Set_Vga

      USB Setup CB:Call AppSTOP3

      AplnStop:SMState = 0x1

      AplnStrt:SMState = 0x2

      UsbCB:Call AppStop4

      AplnStop:SMState = 0x5

      AplnStrt:SMState = 0x1

      Prod = 10 Cons = 4  Prtl_Sz = 14240 Frm_Cnt = 1 Frm_Sz = 19360 B

      UsbCB:Call AppStop4

      AplnStop:SMState = 0x7

      AplnStrt:SMState = 0x1

      Prod = 11 Cons = 19  Prtl_Sz = 14000 Frm_Cnt = 2 Frm_Sz = 19632 B

      UsbCB:Call AppStop4

      AplnStop:SMState = 0x5

      AplnStrt:SMState = 0x1

      Prod = 0 Cons = 8  Prtl_Sz = 15360 Frm_Cnt = 3 Frm_Sz = 15360 B

      UsbCB:Call AppStop4

      AplnStop:SMState = 0x5

      AplnStrt:SMState = 0x1

      Prod = 10 Cons = 12  Prtl_Sz = 4000 Frm_Cnt = 4 Frm_Sz = 9120 B

      UsbCB:Call AppStop4

      AplnStop:SMState = 0x5

      AplnStrt:SMState = 0x1

      Prod = 2 Cons = 8  Prtl_Sz = 12320 Frm_Cnt = 5 Frm_Sz = 13344 B

       

       

      My configure is below:

              CY_U3P_CSI_DF_RAW10,  /* CyU3PMipicsiDataFormat_t dataFormat */

              1,                          /* uint8_t numDataLanes */

              2,                /* uint8_t pllPrd */

              80,            /* uint16_t pllFbd */

              CY_U3P_CSI_PLL_FRS_500_1000M, /* CyU3PMipicsiPllClkFrs_t pllFrs */

              CY_U3P_CSI_PLL_CLK_DIV_8,    /* CyU3PMipicsiPllClkDiv_t csiRxClkDiv */

              CY_U3P_CSI_PLL_CLK_DIV_8,    /* CyU3PMipicsiPllClkDiv_t parClkDiv */

              0,                        /* uint16_t mClkCtl */

              CY_U3P_CSI_PLL_CLK_DIV_2,    /* CyU3PMipicsiPllClkDiv_t mClkRefDiv */

              640,                /* uint16_t hResolution */

              50                            /* uint16_t fifoDelay */

       

       

      How can i check it ?