2 Replies Latest reply on Apr 4, 2019 7:29 AM by jomac_4032611

    Stop current consumption sensitive to light

    jomac_4032611

      My device based on cyble-022001 is supposed to have <<1 uA power consumption when the user (or software) switch is off. Then cyble is in stop mode. I was measuring that and it was taking about 2 uA on my custom board with two sensors and a few 100 nF ceramic caps. When I switched off the small work light I have on my table the consumption dropped to 40 nA! I though this was caused by the sensor, since it measures visible and IR light and for it the standby current is specifically said to be in the dark.

       

      But shadowing different parts with finger or a business card revealed it was definitely the module that changed the current consumption and it was its shielded part.

       

      Is that expected? How much the current will be in direct sunlight? Are deepsleep and hibernate equally affected?

       

      The work light I noticed this with is just a small one with 40 W traditional bulb. And it's about 30 cm from the module not heating it up etc. I also tested with a small LED flashlight, but it had much less effect (~100 nA) although I kept it very close and it was definitely brighter (over the scale of 4000 lx vs. 600 lx according to my sensor).

        • 1. Re: Stop current consumption sensitive to light
          GaneshD_41

          Hi,

           

          This phenomenon is not expected. We expect the issue is because of the temperature. Please do the following tests.

           

          1. Please download empty project in your application and see whether the same phenomena is happening.

          2. Please test with other temperature sources (ones which doesn't produce light) and see if you are observing the same.

           

          Please update in the thread with results once you have done the above tests.

          Thanks

          Ganesh

          • 2. Re: Stop current consumption sensitive to light
            jomac_4032611

            I did some tests with the attached workspace. I didn't quite know how to create a totally empty project with PSoC Creator. All I could find was prepopulated or examples. So I took an example and cleared TopDesing, main.c and removed all other header and source files.

             

            This is a different cyble-022001 on my custom board, which has just the module + a ferrite bead between VCC and cyble-022001 power pins. All other components are not yet on the board and there are no connection to GND, VCC or each other on any pins of the module.

             

            3.0 V from my lab power and currents measured with my Fluke 8060A (quite old, but top of the line model).

             

            First I tested DeepSleep. I got 1.59 uA without the light and 3.68 uA with the light on. The bulb is 30 cm from the module and I can't feel any temperature change due to light. When I switch on and off the change in current is as fast as my Fluke can show, which is 2.5 Hz reading update. I also got the same 1.59 uA while shadowing the module with my finger and keeping the light on.

             

            Then with Hibernate I got 130 nA without the light and 2.02 uA with the light.

             

            WIth stop I got 20 nA without the light and 1.98 uA with the light. Now I could not get 20 nA with a shadow from a finger. I did get around 100 nA. Also switching the light off dropped the current first to 100-200 nA and then it took a few seconds to reach 20 nA. Switching the light on made the current jump right to ~2 uA. Putting the module just 2  cm from the bulb I got 30 uA!

             

            Then I tried to apply heat with my hot air gun set to 200 C. First the current jumped up and down (positive and negative but always well below 1 uA) and then settled to 200-300 nA while the module was clearly hot. So it certainly is not the heat from the light.

             

            I checked to bulb. It is actually only 25 W (240 V) incandescent spot light. 40 W was just the maximum allowed.

             

            With LED flashlight I got only up to 100 nA, but still there was a change.

             

            Finally I tested outside. Direct sunlight increased the stop current to 10-20 uA! The final product will be outside and often in direct sunlight in a transparent enclosure. This is a real problem, since CR2430 is supposed to keep the module in stop mode for many years. With 20 uA it can't even do two years (well no sunshine during night and cloudy days).

             

            I used the same workspace with just changing the device and tried with cy8ckit-143a. I got no effect on current from the lamp. I also tried the part upside down. Stop current was 10-20 nA in all cases.

             

            It seems to be specific to cyble-022001 module. I could change to newer version of the same footprint although I don't need the extra memory, which will just increase current consumption. I'm hoping you can test what causes this behavior and which modules are prone to light. Or send me a few cyble-222014 modules for testing.