8 Replies Latest reply on Apr 29, 2019 6:55 AM by MichaelF_56

    Murata 1DX + STM32F412 based on Murata 1LD

    DaRa_4056336

      Hi,

      I ordered the Murata 1LD but due to long lead time I decided to order Murata 1DX ( using Avnet eval board: AES-PMOD-MUR-1DX-G ) and STM32F412 (using ST eval board: STM32f412Discovery).

      I added Murata 1LD files to my Wiced 6.2.1 files add support for ST-LINK V2.1 (based on article in the blog) and I programmed succesful the STM32F412 but It is don't work.

      Make taget command: snip.bluetooth.serial_gatt_service-MurataType1LD download run

       

      I will add few details about the connections:

       

      My connections:

      PC2 to BT_REG_ON

      PC0 to BT_HOST_WAKE

      PC3 to BT_DEV_WAKE

       

      /* Bluetooth control pins. Used by libraries/bluetooth/internal/bus/UART/bt_bus.c */

      static const platform_gpio_t internal_bt_control_pins[] =

      {

          /* Reset pin unavailable */

          [WICED_BT_PIN_POWER      ] = { GPIOC,  2 },

          [WICED_BT_PIN_HOST_WAKE  ] = { GPIOC,  0 },

          [WICED_BT_PIN_DEVICE_WAKE] = { GPIOC,  3 },

      };

       

      UART Connections:

      PA2 (TX) to BT_RXD_IN

      PA3 (RX) to BT_TXD_OUT

      PA0 (CTS) to BT_RTS_OUT

      PA1 (RTS) to  BT_CTS_IN

       

      /* Bluetooth UART pins. Used by libraries/bluetooth/internal/bus/UART/bt_bus.c */

      static const platform_gpio_t internal_bt_uart_pins[] =

      {

          [WICED_BT_PIN_UART_TX ] = { GPIOA,  2 },

          [WICED_BT_PIN_UART_RX ] = { GPIOA,  3 },

          [WICED_BT_PIN_UART_CTS] = { GPIOA,  0 },

          [WICED_BT_PIN_UART_RTS] = { GPIOA,  1 },

      };

       

      My questions:

      1. The connections are right?

      2. I debugged using the scope and saw STM32F412 transmits and BT_REG_ON is 3.3V , but there is not any response from 1DX, I think I missing something and don't know . After programming I don't find the device in BLE scanner on my phone

      3.  I am able to program but not debug .. I tried to use snip.bluetooth.serial_gatt_service-MurataType1LD download debug but it didn't work

       

      Console log:

       

      Download complete

       

      GNU gdb (GNU Tools for Arm Embedded Processors 7-2018-q2-update) 8.0.50.20171128-git

      Copyright (C) 2017 Free Software Foundation, Inc.

      License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

      This is free software: you are free to change and redistribute it.

      There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

      and "show warranty" for details.

      This GDB was configured as "--host=i686-w64-mingw32 --target=arm-none-eabi".

      Type "show configuration" for configuration details.

      For bug reporting instructions, please see:

      <http://www.gnu.org/software/gdb/bugs/>.

      Find the GDB manual and other documentation resources online at:

      <http://www.gnu.org/software/gdb/documentation/>.

      For help, type "help".

      Type "apropos word" to search for commands related to "word"...

      Reading symbols from build/snip.bluetooth.serial_gatt_service-MurataType1LD/binary/snip.bluetooth.serial_gatt_service-MurataType1LD.elf...done.

      warning: File "C:\Users\david.raisfeld\Documents\WICED-Studio-6.2\43xxx_Wi-Fi\.gdbinit" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".

      To enable execution of this file add

      add-auto-load-safe-path C:\Users\david.raisfeld\Documents\WICED-Studio-6.2\43xxx_Wi-Fi\.gdbinit

      line to your configuration file "$HOME/.gdbinit".

      To completely disable this security protection add

      set auto-load safe-path /

      line to your configuration file "$HOME/.gdbinit".

      For more information about this security protection see the

      "Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:

      info "(gdb)Auto-loading safe path"

      .gdbinit_attach:1: Error in sourced command file:

      (gdb) quit

      localhost:3333: No connection could be made because the target machine actively refused it.

      Build complete

      Making .gdbinit

       

      openocd_log.txt:

      Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD

      adapter speed: 2000 kHz

      adapter_nsrst_delay: 100

      none separate

      srst_only separate srst_nogate srst_open_drain connect_deassert_srst

      Info : Unable to match requested speed 2000 kHz, using 1800 kHz

      Info : Unable to match requested speed 2000 kHz, using 1800 kHz

      Info : clock speed 1800 kHz

      Info : STLINK v2 JTAG v31 API v2 SWIM v21 VID 0x0483 PID 0x374B

      Info : using stlink api v2

      Info : Target voltage: 3.236220

      Info : stm32f4x.cpu: hardware has 6 breakpoints, 4 watchpoints

      Info : Unable to match requested speed 2000 kHz, using 1800 kHz

      Info : Unable to match requested speed 2000 kHz, using 1800 kHz

      adapter speed: 1800 kHz

      target halted due to debug-request, current mode: Thread

      xPSR: 0x01000000 pc: 0x08000610 msp: 0x2001dcdc

      auto erase enabled

      Info : device id = 0x30006441

      Info : flash size = 1024kbytes

      target halted due to breakpoint, current mode: Thread

      xPSR: 0x61000000 pc: 0x20000046 msp: 0x2001dcdc

      wrote 212992 bytes from file build/snip.bluetooth.serial_gatt_service-MurataType1LD/binary/snip.bluetooth.serial_gatt_service-MurataType1LD.stripped.elf in 6.055235s (34.350 KiB/s)

      shutdown command invoked

       

      Any Help ?

       

      Thanks!!!!

      David