3 Replies Latest reply on Mar 28, 2019 12:07 AM by PriyaM_16

    size_t error while compiling

    SaIr_3758621

      Hi,

       

      i'm  getting  compilation error as  error: 'size_t' has not been declared even though the respective header file is included.

      This error is encountered when I tried to include a file in app make file and similar files are included previously which were working fine.

      can you suggest the way to sort out this issue.

      I'm attaching the screenshot of it.

        • 1. Re: size_t error while compiling
          PriyaM_16

          Hello,

          Have you included the header file?

          #include <stdio.h>

          #include <stdlib.h>

           

          I tested a variable in apsta snip and I was able to compile.

          size_t dummy = 0;

           

          Can you please point out the exact steps to replicate the problem?

          1 of 1 people found this helpful
          • 2. Re: size_t error while compiling
            SaIr_3758621

            Yes, I Included stdio.h , stdlib.h   header files and I’m still facing the compilation errors.

            I’m facing the compilation error in the WICED/security/BESL/mbedtls_open/include/mbedtls folder .h

             

             

            Brief on elaborating this issue.

            We have a user defined folder in the apps folder and have included required files for compilation in the apps makefile.

             

            1. My question is when I’m including a file from apps make file but, I’m getting error in WICED folder. How that can be possible??

            Is that we are missing some linking of header files but ,even  tried giving  a relative path but ,didn’t worked.

            2. Apps folder contain same folder mbedtls but it is not included in the compilation which is also present in WICED  in the following path WICED/security/BESL/mbedtls_open/include/mbedtls. Does, this creates a problem  ?? Like having duplication of  files/folders.

            3. I also checked  the compilation removing mbedtls it from apps folder itself, Still facing the issue.

                Interesting fact is the Size_t is perfectly working fine for other files which I had included for compilation before.

            • 3. Re: size_t error while compiling
              PriyaM_16

              Hello,

              can you give me some guidlines on how to replicate the problem in the setup at my end? Any sample application or the changes needed in the files for reproducing the error you are facing.

              I included a variable with size_t in scan application and I do not see any error.

               

              Thanks.