3 Replies Latest reply on Feb 26, 2019 6:24 AM by VinayakS_26

    Issue on Wireless AP & STA mode on BCM43455

    brpa_4047586

      Hello,

       

      I am using Murata WLAN Combo Module SP-HY1MW-F chip which has BCM43455 inside it.

       

      I am using Broadcom generic fmac driver. The firmware & nvram is downloaded from https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/brcm.

       

      I am struggling to enable Wifi AP & STA mode at a time:

      1) When I use connmanctl tether command, it disables the client mode & enables the AP mode, but not both at a time.

      2) When I try creating new interface of managed mode for tethering, it throws an error: Not supported (-95)

      3) When I try creating bridge manually using ip commnd & connecting wlan0 with bridge as a master, it also throws me the error: Not supported (-95)

       

      Can you please help me with the issue?

       

      Thanks & Regards,

      Brinda Pathak

        • 1. Re: Issue on Wireless AP & STA mode on BCM43455
          VinayakS_26

          Hi

           

          Go through the attached document for see if this helps in setting up APSTA.

          We are using clients of hostapd and wpa_supplicant for setting up AP and sta respectively. Could you check whether you are creating the Ap in the virtual interface that is created(wlan1 in the document). Try setting up the STA in the primary interface and AP in the virtual interface and see if it passes.

           

          Regards,

          Vinayak

          2 of 2 people found this helpful
          • 2. Re: Issue on Wireless AP & STA mode on BCM43455
            brpa_4047586

            Thanks a lot Vinayak for the detailed explaination.

            I am still getting the below error on ./hostapd /etc/hostapd.conf -B command.

             

            [  136.380603] brcmf_link_down: WLC_DISASSOC failed (-11)

            [  136.568104] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

            wlan1: interface state UNINITIALIZED->ENABLED

            wlan1: AP-ENABLED

            [  137.040578] brcmf_sdio_hostmail: Unknown mailbox data content: 0x40012

            [  139.520212] brcmf_sdio_bus_rxctl: resumed on timeout

            [  142.080204] brcmf_sdio_bus_rxctl: resumed on timeout

            [  142.085258] brcmf_c_set_joinpref_default: Set join_pref error (-110)

            [  144.640211] brcmf_sdio_bus_rxctl: resumed on timeout

            [  147.200253] brcmf_sdio_bus_rxctl: resumed on timeout

            [  147.205307] brcmf_cfg80211_connect: BRCMF_C_SET_SSID failed (-110)

            n[  149.840214] brcmf_sdio_bus_rxctl: resumed on timeout

            [  149.845264] brcmf_do_escan: error (-110)

            [  149.849223] brcmf_cfg80211_scan: scan error (-110)

            [  152.400225] brcmf_sdio_bus_rxctl: resumed on timeout

            [  152.405670] _brcmf_set_multicast_list: Setting mcast_list failed, -110

            [  154.960263] brcmf_sdio_bus_rxctl: resumed on timeout

            [  154.965736] brcmf_do_escan: error (-110)

            [  154.969705] brcmf_cfg80211_scan: scan error (-110)

            • 3. Re: Issue on Wireless AP & STA mode on BCM43455
              VinayakS_26

              Could you try using the firmware that is present in the latest manda release present in the community.

              Cypress Linux FMAC (Manda)

               

              BR

              -Vinayak

              1 of 1 people found this helpful