8 Replies Latest reply on Feb 19, 2019 1:56 PM by MoTa_728816

    Programming with MiniProg3

    niprc_3742601

      Hello,

       

      I have a PsoC4 L-Series Pioneer Kit (CY8CKIT-046).  I am trying to learn how to program and debug its PSoC5 processor with a MiniProg3.  So I connect my MiniProg3 device to the PSoC5 JTAG header (J7).  Here is the setup

       

      PSoC5.jpg

       

      Then I build a simple application that toggles a signal on a given pin every second.  However, PSoC Programmer gives me this error when I try to program the chip:

       

                                                                     FAILED! PSoC device is not acquired! Check connection of the chip to the programmer

                                                                    Please, check the following items:

                                                                      - the connection between the programmer and the PSoC;

                                                                      - the correct programming protocol is selected;

                                                                      - the correct connector option is selected.

       

       

      - MiniProg3 is connected to my workstation that runs PSoC Programmer, and MiniProg3 is connected to the board

      - The programming protocol selected is JTAG, that corresponds to my setup

      - The connector is PSoC5 Prog header

       

      What am I doing wrong?  Please help!

       

      Thanks!

      Nikolay

       

      P.S.

       

      I attach two projects: one runs on PSoC5 and writes to a pin, the other runs on PSoC4 processor of the same board, reads the pin and turns LED blue if it reads 1 and green if it reads 0.

        • 1. Re: Programming with MiniProg3
          JoMe_264151

          Try the following:

          Disconnect the USB from your board.

          Use Creator to program the project

          Set the miniprog to SWD and 5V.

           

          Easiest debugging will be done under Creator IDE

           

          Bob

          1 of 1 people found this helpful
          • 2. Re: Programming with MiniProg3
            niprc_3742601

            Hi Bob,

             

            thanks for helping me out!

             

            -If I disconnect USB then it complains that device is not powered

            -When I select 5V, I get this

             

             

            We design a board that has a PSoC5 on it.  It will have SWD interface to the PSoC5 processor.  So I am trying to learn how to program it connecting directly via SWD.  The goal is to use MiniProg3 connected to the board on one side and workstation with PSoC Creator on the other for programming and debugging.  At this moment, with this setup, I cannot program the processor neither with PSoC Creator nor PSoC Programmer.

             

            Do you have any ideas what am I doing wrong here?

             

            Thanks!

            Nikolay

            • 3. Re: Programming with MiniProg3
              MoTa_728816

              Hi, Nikolay-san,

               

              The dialog is warning you if the device connected to the MiniProg3 is either CY8C6xxx or CYRF89xxx, you will burn the device.

              But the device you are trying to connect is CY8C5868LTI-LP039, so it should be OK to proceed.

              Meantime, please note that if you change the firmware on the PSoC 5LP of CY8CKIT-046, the KitProg function will be lost till you restore the firmware.

               

              moto

              • 4. Re: Programming with MiniProg3
                niprc_3742601

                Dear Moto-san,

                 

                I tried 5V setting  with SWD and with JTAG, but the result is not different than before.

                 

                I was able to program this PSoC5 processor in the Bootloader mode via USB connector, and then was able to restore KitProg back.  Now I need to learn how to program a PSoC5 processor via SWD since this is how our custom board is designed.  So our plan is to connect MiniProg3 to our board and program/debug from PSoC Creator.

                 

                The eval board that I have on hands has two JTAG headers: J6 and J7.  J6 is for PSoC 4200L Programming and J7 is for PSoC 5LP programming (actually, we attached the header to the J7 pins ourselves).

                 

                When I attach MiniProg3 to J6 (PSoC4's header) then I can successfully program the board's PSoC4 processor.  However, when I connect MiniProg3 to J7 to program the board's PSoC5 processor, then I am having issues described above.

                 

                Do you have any ideas what can be wrong here?

                 

                Meanwhile, we are buying PSoC5 eval board to see if we are more successful with it.  But even if we are then I still want to know what's wrong here in case we have the same problem with our custom made board.

                 

                Thank you for help!

                Nikolay

                 

                img1.jpg

                • 5. Re: Programming with MiniProg3
                  MoTa_728816

                  Dear Nikolay-san,

                   

                  Would you try

                  (1) As Bob-san wrote earlier, I think that you need to disconnect USB-Mini cable from the board.

                  (2) From the menu Debug > Select Debug Target...

                      select Port Setting in the "Select Debug Target"

                      and let the MinProg3 provide power

                      on the board as you are selecting 3.3V for I/O may be providing 3.3V is better

                  (3) Try program 5LP

                   

                  Best Regards,

                  16-Feb-2019

                  Motoo Tanaka

                  1 of 1 people found this helpful
                  • 6. Re: Programming with MiniProg3
                    XiaoweiZ_71

                    I assembly a 10-pin header on J7 of 046 kit, also try to program P5LP devices through Miniprog3 +PSoC Programmer, i get different test result with you.

                    IMG_20190218_104002.jpg

                     

                    Step1: Open PSoC Programmer, connect 046 Kit to PC and also connect Miniprog3 with J7 and PC. Choose Miniprog3 in 'Port Selection' windows of PSoC Programmer, then click JTAG tab and press 'Scan Bus' button to scan the JTAG chain. Without this step, sometimes Miniprog3 cannot detect the JTAG devices on JTAG chain successful.

                    S1.JPG

                    Step2: Switch to Programmer Tab and click Program Icon to program the device, the P5LP device can be programmed successful. Only Miniprog3 can be emulated in port selection window, Kitprog will be emulated also until you unplug and plug the USB cable from J10.

                    S2.JPG

                     

                    Step3: Choose SWD interface, press Program icon can program the P5 LP device directly. No errors.

                    S3.JPG

                     

                    My test platform:

                    OS: Win10 Pro

                    Miniprog3: rev*B

                    PSoC Programmer: Version 3.28.0.4154

                    P46 Kit: Rev06

                     

                     

                    3 of 3 people found this helpful
                    • 7. Re: Programming with MiniProg3
                      niprc_3742601

                      Hello,

                       

                      Thank you, everybody, for your help!

                       

                      I have made some great progress and now can program the PSoC5 processor on the board!  But I still cannot use debugger with the PSoC5 code.

                       

                      I followed the advice from Motoo-san and from the Select Debug Target dialog box

                       

                       

                      opened Port Setting

                       

                       

                      and changed Power to "3.3 V" from "External".  This alone let me program the processor.

                       

                      Also, I tried to do what user VisionZ_71 suggested, but the Scan Bus button was grayed out (see below).  Device Family and Device settings are selected for PSoC4.  I wonder if this is the reason why the Scan Bus button is disabled.  However, I cannot change the settings to PSoC 5 since they are also grayed out.

                       

                       

                      Also, I can program the chip now, but I cannot use debugger: the debug option is grayed out in PSoC Creator.  Any ideas why?

                       

                      Again, thank you, everybody, for your help!

                       

                      Thanks,

                      Nikolay

                      • 8. Re: Programming with MiniProg3
                        MoTa_728816

                        Dear Nikolay-san,

                         

                        I think that to use scan-bus feature, you need to select "JTAG" instead of "SWD"

                        This is the reason why we needed to tweak SWD signals in the previous discussion,

                        as SWD is not supporting multiple devices.

                         

                        You may also want to try "JTAG" protocol for debugging if the tool allows us to do so.

                         

                        Best Regards,

                        20-Feb-2019

                        Motoo Tanaka