5 Replies Latest reply on Feb 18, 2019 2:04 AM by roscc_1579236

    UART fried or deactivated? PSoC 4200 / CYKit8

    roscc_1579236

      Dear Community, the other day I tried to make a linear servo, using the optical position sensor and DC motor of an old printer's ink cartridge carrying mechanism. for debugging, the position was supposed to be transmitted to my PC via UART, which had worked perfectly before.

       

      I also had debugging LEDs involved, one for each of the 2 photodiode channels of the position sensor to tell if each channel was bright or dark. For this, I wanted to use 2 colors of the onboard RGB LED.

       

      I gradually implemented the motor control hardware using an L293D chip powered by external 5V Power supply capable of pulling high currents. Unaware that these Pins also were assigned to the RGB-LED channels, I began assigning one of the Motor control pins to P0.2.

      I'm not sure of the chronology but once I had an issue where pins were reassigned automatically, and also many attempts of reassigning the pins manually.

       

      The end result was that the status LED did a green fading blink, around 1 cycle/minute and my terminal emulator did not recognize the Device as a serial Port anymore, while anything else in the routine seemed to function as normal.

      This situation kept being the case and still persists for any Project that uses UART and was working perfectly before.

       

      My questions now:

      - Did I fry something vital for UART connections?

      - Is there a troubleshooting guide somewhere to look up status led blinking schemes?

       

      Thank you very much in advance, I'll provide any available further info as needed!