2 Replies Latest reply on Feb 25, 2019 10:13 PM by ZhengbaoZ_96

    how to disable delayed ACK on the WICED platform ?

    JaSh_2812831

      -I am using MQTT on the CYW943907AEVAL1F board.

      -224.226 is my  CYW943907AEVAL1F, and 224.212 is the server.

       

      -We can observe that the ACK packet (numbered 2117) is sent after ~190ms. And due to this, unless the server receives the ACK, it would not publish the message back to the board, hence increasing the total delay for completing the transaction

      -I did modify the NX_TCP_IMMEDIATE_ACK and NX_TCP_ACK_TIMER_RATE in the NetX Duo (/43xxx_Wi-Fi/WICED/network/NetX_Duo/ver5.7_sp2/nx_tcp.h), but it did not change anything. I think it is because the WICED does not recompile NetxDuo every time. If that is correct, how do I recompile Netx_Duo?

      -Or is there are a way to disable delayed ACK on WICED SDK?