2 Replies Latest reply on Feb 4, 2019 1:26 PM by brmic_1324281

    Can't program a custom app into kitprog2 - progammer returns Command not recognized

    brmic_1324281

      I am trying to program a custom program into a kitprog2 board (from a CY8CKIT-059 and at kitprog latest version 2.21) . I am following the instructions contained in the Kitprog2 User Guide    Doc. # 002-10738 Rev. *K   in section 9.1.

      I am starting out using the KitProg2_Custom_App.zip file quoted in this guide. The device is set up as a CY8C5868LTI-LP039, as shown in the guide.

      I specify bootloader.hex, elf (as dependencies for the bootloadable component) - I tried both from the programmer and the CY8CKIT-059 folders that are quoted in the guide.

      The project builds correctly with no errors.

      When I run tools/ Bootloader Host,I first load the KitProg2_Custom2.cyacd file from the \project folder\CortexM3\ARM_GCC_541\Debug  folder

      In the guide, it shows USB VID/PID as 04B4/F146. However, my kitprog2 enumerates as 04B4/F139 when plugged in normally, and 04B4/013B if I push the SW3 while plugging it in (i.e. bootloader mode). So, I set the filter to 04B4/1F3B. I press SW3 while plugging it into USB port. Green LED blinks at 1 Hz

      When I hit Program I get the error: "the bootloader reported error 'command not recognized: ....."

      program failed in 70 ms

        At this point the green light is on full time.  It will go back to blinking if I power it down and plug it back in with SW3 pressed.

      kitprog2 still works as a programmer if I plug it in normally (SW3 not pressed)

       

      Any help available? I think I am following all Cypress instructions correctly. Also, I can load bootloadable projects properly into the PSoC5LP target MCU in the CY8CKIT-059 kit.

      Thanks

        • 1. Re: Can't program a custom app into kitprog2 - progammer returns Command not recognized
          himam_31

          Hello,

           

          Can you try with the Kitprog  .hex file instead of kitprog2 hex file. The kit CY8CKIT-059 has the Kitprog firmware and not Kitprog2. Please refer to the Kitprog user guide.

           

          Thanks,

          Hima

          • 2. Re: Can't program a custom app into kitprog2 - progammer returns Command not recognized
            brmic_1324281

            Hello HimaM:

               Thanks for your quick response. You are correct- that worked. I am embarrassed- I knew the programming board that came with my older PSoC4xxx prototype boards was different/less capable than the programmer on the CY8CKit-059/PSoC5LP boards. I just assumed that the programmer on the CY8CKIT-059 was kitprog2 (and the one on the 42xx boards was kitprog1). Also, as soon as I plugged in either of my  programming boards from an earlier -059 kit, or the -059 kit that I just bought, they both called for a firmware update. The update brought them up to version 2.21. I assumed the leading 2 was for kitprog2. Also, my newly-purchased  CYPROTO-063 board came with  kitprog2 originally, but after the (mandatory) update, it now appears as a kitprog3.

              In any case, it works fine now. Plus, the board's VID/PID now match the Kitprog docs, where they were different from the ones in the kitprog2 docs.

            Thanks again