3 Replies Latest reply on Jan 29, 2019 8:58 AM by MaMc_3367101

    CYBLE-012011-00 UART Baud Rate Issue?

    MaMc_3367101

      I've created a fresh project based on the fixed stack Bootloader / Bootloadable projects and have an issue with readable data from the UART TX. I've made sure my UARTs are set for 57600 on both projects and made sure to read at 57600 from my terminal apps(tried multiple, putty, screen). I'm using the included UART debugging code in both projects with the same results. Could my baud rate still be an issue here and if so, how can I calculate or find what my baud rate should be?

       

      I do see data in the terminal but it looks like a baud rate issue no what what baud rate I try. I've tried all preconfigured rates, 9600 - 115200 on both projects and terminal.

       

      screen -L /dev/tty.usbserial-14630 57600

      ^S/]P]*P\_P^X,,]^P[,1ƣ^S/]P]*P\_EqQ1EQ11QqE^S/]P]*P\_VP1QqEP+]Wc$ODa3fX+bD$1ƣX+bD$1Fƣ

       

      My project settings are all default.

      #define DEBUG_UART_ENABLED      (YES)

      /* YES - use printf, NO - use UART_PutString

      * e.g. DBG_PRINTF("message %d\r\n", i) will transform to UART_PutString("message %d\r\n") */

      #define DEBUG_UART_USE_PRINTF_FORMAT  (YES)