3 Replies Latest reply on Jan 25, 2019 2:18 PM by sccl_2272156

    Routing of net __ZERO__ failed

    tiphc_1376351

      My program compiles with optimization.  But when I turn optimization off in Project->Build Settings->Synthesis Optimization Effort, the program fails to compile.  The error message is "Routing of net __ZERO__ Failed."

       

      Why can't I turn optimization off?

        • 1. Re: Routing of net __ZERO__ failed
          sccl_2272156

          If you turn synthesis optimization off, your design may just be using too many routing resources in the UDB array to route.

           

          Generally you should not turn off synthesis optimization.  Your design will run slower, be harder to debug and use more resources if you turn off the optimization.  So let me ask, what were you trying to do in turning this off?

          • 2. Re: Routing of net __ZERO__ failed
            tiphc_1376351

            I turn off optimization whenever I am developing code.

             

            On Fri, Jan 25, 2019 at 3:48 PM ScottA_91 <community-manager@cypress.com>

            • 3. Re: Routing of net __ZERO__ failed
              sccl_2272156

              Ah, you turned digital logic synthesis off.  (Meaning the wires and hardware logic your components are implemented using, not the code.)  That will not make your code any easier to debug.  It will cause timing issues and routing failures.

               

              You want to turn code optimization off.

               

              The standard debug settings are pretty good for that, but if you want to change it, right click on your project in the Workspace Explorer and select Build Settings.

              Click on your compiler (for me ARM GCC) and expand it.

              Expand the Compiler item

              Click on Optimization and change the level to whatever you want.