2 Replies Latest reply on Jan 21, 2019 10:16 PM by user_1654946

    PSoC6 Pioneer Board not running the code with Free RTOS

    user_1654946

      Hello everybody,

       

      After some time spent using PSoC 4 BLE chips for a project, we are going to test the PSoC 6 boards for another similar project. In this moment I am using a PSoC6 Pioneer Board with BLE one of the first revisions sold by Mouser (it is REV 08) and we encounter some problems. I will detail the problems and then some lines about the project that we are trying to port from PSoC4.

      1) We have tried the Modus toolbox using a macbook pro machine and used only the hello world test problem. The code compiles but we are unable to run it and we just found this thread https://community.cypress.com/message/184259#184259 .

      2) We just switch to PSoC Creator 4.2 and run there an example the Blinking dual core. Everything is ok, therefore we though we will go with creator until we receive new boards.

      3) We just create a  project by adding some pins and components that we may use (no BLE or anything fancy). Then just toggle Free RTOS and retarget middleware for prints and create one simple thread to blink the red LED. We program the board successful but the code is not running. We than create another thread for printing at  2 seconds a text on uart, and in cool term terminal noting appear. We believe the code is not running on the board for some reason, maybe we did something wrong in the setup or the board is to early released. Hopefully we did something wrong.

       

      Detail of the project: We need 12 analog lines but the creator is not able to route the analog lines therefore we used 12 analog pins, a HW MUX and an ADC with one single-ended channel. Moreover we have 3 SCBs, one I2C for multiple sensors we used, the debug UART only for TX and an UART for a communication modem. Alongside these components we use several digital output pins, and of course the red LED for the test described.

       

      See attach test project.

       

      Best regards,

      Marian

        • 1. Re: PSoC6 Pioneer Board not running the code with Free RTOS
          MoTa_728816

          Hi,

          I tried your project and noticed some points

          (1) To use FreeRTOS, we must set Memory Management in Build Settings -> Peripheral Driver Library

          Build_setting_RTOS_FreeRTOS_Memory_Management.JPG

          (2) Somehow your WCO setting was  "Bypass (External sine wave)"

          So I changed it to "Normal (Crystal)"

          019-Config-WCO.JPG

          (3) By doing above, PSoC Creator regenerated application, and over written "stdio_user.h" to the default contents

          020-retoro.JPG

          So I re-entered usual stuff

          > #include "Project.h"

          > SCB0 -> UART_HW

          014-stdio_user_h.JPG

          Then I built and ran your project with CY8CKIT-062-BLE Rev. 08 and it seems to be working ;-)

          018-UART_Working.JPG

           

          moto

          • 2. Re: PSoC6 Pioneer Board not running the code with Free RTOS
            user_1654946

            Hello,

             

            Thank you a lot. It seems that the only problem was the WCO. I change the crystal as you mentioned and everything started.  The FreeRTOS had the memory management set to heap_4 and it did not influenced the running of the code, only the WCO did.

            I do not know why it was bypassed and to be honest I did not checked since we have just created the project as empty and added the circuits in creator.

            Bottom line, thank you for your fast and awesome response!

             

            Best regards,

            Marian