2 Replies Latest reply on Jan 18, 2019 12:29 AM by RaktimR_11

    Snip.websocket_client doens't work with TLS

    HyCh_2920631

      snip.websocket_client worked without TLS(comment the line #define USE_WEBSOCKET_SECURE_CLIENT.) however failed with TLS in SDK 6.2

       

      Below log is failed log (with TLS)

      ---------------------------------------------------------------------------------------------

      Connecting to server... 

       

      Trying to connect

      Not a valid IP address?? Trying hostname lookup...

       

      Error number received = 1 

      [websocket_tls_connect] Error[7014] connecting @websocket: 0x4e549c

       

      Error number received = 1

      ------------------------------------------------------------------------------------------------

      How do I fix this error?

        • 1. Re: Snip.websocket_client doens't work with TLS
          RaktimR_11

          Thanks for reporting this issue. We will raise this request internally to fix this issue and provide the same once there is a fix available.

          • 2. Re: Snip.websocket_client doens't work with TLS
            RaktimR_11

            You can use the below certificate to check if the connection process is going through without any hiccups.(Assuming you are using echo,websocket.org as the webserver)

            "-----BEGIN CERTIFICATE-----\n"\

                    "MIIDSjCCAjKgAwIBAgIQRK+wgNajJ7qJMDmGLvhAazANBgkqhkiG9w0BAQUFADA/\n"\

                    "MSQwIgYDVQQKExtEaWdpdGFsIFNpZ25hdHVyZSBUcnVzdCBDby4xFzAVBgNVBAMT\n"\

                    "DkRTVCBSb290IENBIFgzMB4XDTAwMDkzMDIxMTIxOVoXDTIxMDkzMDE0MDExNVow\n"\

                    "PzEkMCIGA1UEChMbRGlnaXRhbCBTaWduYXR1cmUgVHJ1c3QgQ28uMRcwFQYDVQQD\n"\

                    "Ew5EU1QgUm9vdCBDQSBYMzCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEB\n"\

                    "AN+v6ZdQCINXtMxiZfaQguzH0yxrMMpb7NnDfcdAwRgUi+DoM3ZJKuM/IUmTrE4O\n"\

                    "rz5Iy2Xu/NMhD2XSKtkyj4zl93ewEnu1lcCJo6m67XMuegwGMoOifooUMM0RoOEq\n"\

                    "OLl5CjH9UL2AZd+3UWODyOKIYepLYYHsUmu5ouJLGiifSKOeDNoJjj4XLh7dIN9b\n"\

                    "xiqKqy69cK3FCxolkHRyxXtqqzTWMIn/5WgTe1QLyNau7Fqckh49ZLOMxt+/yUFw\n"\

                    "7BZy1SbsOFU5Q9D8/RhcQPGX69Wam40dutolucbY38EVAjqr2m7xPi71XAicPNaD\n"\

                    "aeQQmxkqtilX4+U9m5/wAl0CAwEAAaNCMEAwDwYDVR0TAQH/BAUwAwEB/zAOBgNV\n"\

                    "HQ8BAf8EBAMCAQYwHQYDVR0OBBYEFMSnsaR7LHH62+FLkHX/xBVghYkQMA0GCSqG\n"\

                    "SIb3DQEBBQUAA4IBAQCjGiybFwBcqR7uKGY3Or+Dxz9LwwmglSBd49lZRNI+DT69\n"\

                    "ikugdB/OEIKcdBodfpga3csTS7MgROSR6cz8faXbauX+5v3gTt23ADq1cEmv8uXr\n"\

                    "AvHRAosZy5Q6XkjEGB5YGV8eAlrwDPGxrancWYaLbumR9YbK+rlmM6pZW87ipxZz\n"\

                    "R8srzJmwN0jP41ZL9c8PDHIyh8bwRLtTcm1D9SZImlJnt1ir/md2cXjbDaJWFBM5\n"\

                    "JDGFoqgCWjBH4d1QB7wCCZAA62RjYJsWvIjJEubSfZGL+T0yjWW06XyxV3bqxbYo\n"\

                    "Ob8VZRzI9neWagqNdwvYkQsEjgfbKbYK7p2CNTUQ\n"\

                    "-----END CERTIFICATE-----\n";

            We have also noticed some other issues regarding continued frame in websocket library subsequently which are being worked on.

            1 of 1 people found this helpful