4 Replies Latest reply on Jan 31, 2019 11:06 PM by BragadeeshV_41

    Capsense 2.6 in Creator 4.2???

    DaZh_2976111

           when used the capsense2.6 in creator 4.2, in the datesheet that tuner function is Capsense_TunerStart() and Capsense_TunerComnm(), but they can run in capsense , it shows error , so why, why ,why,   why not used the same the api , to change the API but it's not common used in the different version Component ???    

        • 1. Re: Capsense 2.6 in Creator 4.2???
          BragadeeshV_41

          Hi,

           

          The capsense component v2.x uses the Capsense_TunerStart() API initializes CapSense CSD and internal communication components, initializes baselines and starts the sensor scanning loop. The CapSense_TunerComm() establishes communication with the Tuner GUI.

           

          In v3.0 and above, the Capsense_TunerStart() API is discontinued and the tuner is started(initialized) inside the Capsense_Start() itself. See the Capsense_Start() in Capsense_Control.c file. You can find the Capsense_Initialize() function inside Start(). Inside Initialize() function, you can find  CapSense_TuInitialize() that initializes tuner. Capsense_RunTuner() is used to synchronize communication with the tuner in v3.0 and above.

           

          We highly recommend you to use the latest Capsense version in your project.

           

          Hope this helps!

           

          Regards,

          Bragadeesh

          • 2. Re: Capsense 2.6 in Creator 4.2???
            DaZh_2976111

                   but in the lastest capsense V6.0, there are some issue with pos4000  withe creator 4.2,  can't download , but it's ok in creator3.3, wiht capsense V3.0/2.X, don't know how to slove it, tks;

            • 3. Re: Capsense 2.6 in Creator 4.2???
              BragadeeshV_41

              Hi,

               

              Could you please let me know what is not downloadable? I tried to use v6.0 component in 4000 device using PSoC Creator 4.2. The project built without error.

               

              Screenshots of your error message will be helpful.

               

              Also you need to note that v6.0 is not backward compatible. The older version ( 2.x) needs to be manually migrated to the new component. Just changing the component alone to the old project ( that used older version before ) will not work. You can refer to the component migration guide in the Capsense Component datasheet (Pg 152)

              http://www.cypress.com/file/442046/download

               

              Regards,

              Bragadeesh

              • 4. Re: Capsense 2.6 in Creator 4.2???
                BragadeeshV_41

                This thread has been locked due to inactivity for more than three weeks.

                 

                -Cypress Semiconductor