6 Replies Latest reply on Jan 14, 2019 7:11 PM by VisonZ_71

    CY8C5267AXI-LP051 consume problems

    VladiGalliano

      Hello,

       

      I have observed when programing CY8C5267AXI-LP051 via MiniProg3 that when I mount the microcontrolers with recommended capacitors in VDDD,VCCD,VCCA and VDDD increase current that cosume after that few minutes in use and finally Miniprog3 identify CY8C5267AXI-LP051 like ARM-Debug.

       

      I follow the rules about kit CY8CKIT-001B exactly the CY8C58LP module for the capacitors connection of VDDD,VDDA,VCCD and VCCA. But the problem persist. When current arrive to 14mA microcontroller makes a reset so finally i cant program the CY8C5267AXI-LP051 but after pass several days, if I can program CY8C5267AXI-LP051, is it probably capacitor problem?

       

      I attach my scheme:

      pcb-route.PNG

      Thank you

        • 1. Re: CY8C5267AXI-LP051 consume problems
          VisonZ_71

          Does the consume current increase slowly or just lift up suddenly after few minutes in use?

          How many boards can reproduce this issue?

          Does silicon hot when this happened? 

           

          I recommend you measure voltage on VDDA/VDDD/VCCA/VCCD/VDDIO pins and confirm if voltage level is correct. If you have multiple boards,chip exchange experiment is the easiest way to find out it is silicon issue or board issue.

           

           

           

           

          • 2. Re: CY8C5267AXI-LP051 consume problems
            VladiGalliano

            Does the consume current increase slowly or just lift up suddenly after few minutes in use?

            The current start to increase in few minutes, its not suddenly. When current supply arrive to 120mA the microcontroller makes reset and current drops up to 20-30mA, after this the microcontroller does not stop programming at the moment. Bt After several hours I can program the microcontroller.

             

            How many boards can reproduce this issue?

            At the moment in two different pcb's.

             

            Does silicon hot when this happened?

            No, I use IR thermomemeter and the silicon no increase our temperature.

             

            I recommend you measure voltage on VDDA/VDDD/VCCA/VCCD/VDDIO pins and confirm if voltage level is correct. If you have multiple boards,chip exchange experiment is the easiest way to find out it is silicon issue or board issue.

             

            The voltage supply is 3.3V, its the same in VDDD,VDDA and VDDIO1-4. The VCCA is 1,782 and VCCD is 1,875V. The voltage perform are perfectly.

             

            But now We have detected when we set XRES to VDDD this problem disappear and the current get to stabilize between 5-11mA.

            Furthermorewhen supply is off we have realized that the XRES impedance drop out 4,7 MOhms too few 0.8Kohm.

             

            In CY8CKIT-059 pcb does not mount Capacitor and resistor to XRES. Is it possible to use in CY8C

            • 3. Re: CY8C5267AXI-LP051 consume problems
              VisonZ_71

              XRES pin has an internal 5.6K ohm pull-up resistor to VDDIO1, which can promise this pin keeps high in idle, so external capacitor and resistor to XRES is not a MUST choice (through we recommend use).  I test two PSoC5 processor modules, no matter chip is powered up or powered off, the XRES-to-GND impedance is very large,  800 ohm impedance seems abnormal.

               

              Could you please monitor the voltage on XRES pin when issue reproducing? I suspect the voltage on XRES is not equals to VDDIO1 when issue reproduce.

              • 4. Re: CY8C5267AXI-LP051 consume problems
                VladiGalliano

                Hello,

                 

                We had triying to use external pull-up resistor and capacitor the same way that CY8CKIT-059 but the problen persist.

                its as if the internal resistor between XRES to GND would have reduced its value but After that we have realized that we set XRES to VDD (3.3V), our consuming problem have disappear.

                 

                it is for that reason that We have asked if it could be a CY8C5267AXI-LP051 problem due to before we used to use and we didn't find this issue.

                 

                Thank you a lot.

                • 5. Re: CY8C5267AXI-LP051 consume problems
                  VladiGalliano

                  Hello,

                  We have seen this warning in Farnell: https://es.farnell.com/cypress-semiconductor/cy8c5267axi-lp051/mcu-32bit-cortex-m3-67mhz-tqfp/dp/2306525?scope=partnumbe…

                  WARNING:

                  ESD sensitive device, take proper precaution while handling the device.

                   

                  This warning is new. it didn´t appear when we worked at the last moments.

                   

                  Thanks

                  • 6. Re: CY8C5267AXI-LP051 consume problems
                    VisonZ_71

                    There shouldn't have low internal resistor between XRES to GND, this is abnormal.  You can measure the resistance between XRES pin and GND on CY8CKIT-059 Kit or other PSoC5 LP board(which cannot reproduce this issue), the resistance should be at least M ohm level.  It looks like the silicon is broken if the resistance is only K level or even less.

                     

                    The warning "ESD sensitive device, take proper precaution while handling the device." is noted by this web i think, Cypress official did not provide such warning.