1 Reply Latest reply on Jan 2, 2019 8:02 PM by YuxianL_01 Branched to a new discussion.

    Issues with FRAM CY15B104Q-SXI SPI communication



      I cannot get my FRAM CY15B104Q to respond to any SPI commands. SO remains Tri-Stated.


      I have placed a 4.7 k pull-up resistor on the CS signal.  I cannot meet the spec of > 50 kV/us for power up, I get around 34 kV/u but the supply is from a linear regulator (not switch mode) and ramps up without any glitches.  I have attached a scope of the power up sequence.  I am measuring on the pins of the device and have disconnected the SO output from the circuit so the processor is not influencing it.


      I am using an STM32H7 Nucleo board which I have used with FRAM FM25V02 32K with a NUCLEO and Waveshare boards before without any problems.


      I meet the power up time requirement of 1 ms.


      I have attached a RDSR Op-code sequence which shows the lack of output.  My understanding of the documentation says that Bit 6 should be 1.


      I have tried the RDID command and again and also get no output from the SO pin.


      I have tried two devices with the same result.


      I sourced the devices from Mouser Australia December 2018.  I have attached a photo-micrograph of the device. The chips came embedded in conductive foam and I handled them on an earthed pad with wrist band.


      Another interesting fact is that the Vdd  standby current of both devices is around 2.4 mA when not being clocked which is a lot more than the spec sheet of 150uA max.


      The numbers on the chips are:






      I notice that other people have had similar problems, ( but there didn't seem to be an answer.


      I have had good results with other Cypress FRAM and am a bit disappointed in this version. I don't wish to change to MRAM or Flash as I require a low power memory. The device will be used on a battery powered wearable medical monitor. I am only using the Nucleo for software development.


      Best Regards