10 Replies Latest reply on May 2, 2015 1:58 PM by userc_7511 Branched to a new discussion.

    Custom Hardware Stops

      I have a wired issue.

       

      I program any example into the BCM20737TAG, I trace using putty the output. I can see :

       

       

      hello_sensor_create()
      1.00
      0118
      0018
      021600002a
      48656c6c6f0000000000000000000000
      021800012a
      0002
      2320567c05cf6eb4c341772851827e1b
      322a0026f6699168eec2be444db95c3f
      2dc38a
      48656c6c6f2030
      0000
      0a2d001a89074a2f3b7ea681443ff9a8
      f29b5e
      00
      0a18
      024f00292a
      42726f6164636f6d
      025100242a
      3132333400000000
      025300232a
      93b863805f9f9171
      0f18
      026300192a
      64
      02010603190002060948656c6c6f
      020a04
      
      permission check retCode = 00
      01
      0100
      2320567c05cf6eb4c341772851827e1b
      02010511072320567c05cf6eb4c34177
      2851827e1b060948656c6c6f
      
      blecm evt handler:
      0e0401082000
      
      blecm evt handler:
      0e0401092000
      
      blecm evt handler:
      0e0401082000
      
      blecm evt handler:
      0e04010a200c
      
      blecm evt handler:
      0e0401062000
      
      blecm evt handler:
      0e04010a2000
      @$*#04FFF6F70092011E0300C1E804640000008003BA1A002800008003BE1A000000008003AE1A620000008003B21A020000008003B61A050005008003BA1A032800008003BE1A000000008003AE1A630000008003B21A020000008003B61A010001008003BA1A192A00008003BE1A000000008003DA1A0000000000074A05126A732000074E05AFCE0000000782061100010000078206040100000007820603100E000007820620000F000007820601201C000007A207000001000007A607000000000007D2070000000000071A080100000000078A08010000000007EE07000000000007A2080000000000E5490B010000000007362A0100E803@$*#04FF1EF7009201030000073A2A500000000007522A500001000007021F01000000hello_sensor_timeout:0
      
      hello_sensor_timeout:1
      
      hello_sensor_timeout:2
      
      hello_sensor_timeout:3
      
      hello_sensor_timeout:4
      
      hello_sensor_timeout:5
      
      hello_sensor_timeo
      ut:6
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      
      

       

      But when I flash my custom hardware, the lines 1 to 54 shows up. But nothing else more.

      (EDIT : Hello_sensor_timeout:0 doesnt shows up on my hardware)

       

      And this is the same case for any example basically, I haven't tried all.

      I tried spi_pressure_sensor as this one doesn't have too much hardware used. I did comment all GPIO and SPI function in the c file, and same issue. The BCM TAG works, and my hardware doesn't.

       

      1 exception is when I'm flashing "hello_client" exemple, this example doesn't make my hardware "hang".

       

      I'm using SDK 2.1.0,

      My board has a BCM20737S chip.

       

      Any idea ?

      Thanks