2 Replies Latest reply on Nov 22, 2018 2:02 PM by contacto_3879486

    PSoC6 debug stopped work after trying secure_image example

    contacto_3879486

      Hi,

       

      I'm working with PSoC6 BLE Pioneer Kit.

       

      I've developed an application for PSoC6 and it worked fine. Then I tried to include it as a secure project.

       

      First of all, I wanted to know how PSoC6 security mechanisms worked, I've read the AN221111 Application Note and I've tried first with your demo application which only blinks the LED. Then I compiled first the secure image, then the user_app0 project, and I've downloaded it to the board.

       

      LED didn't blink, so I tried to put the project in debug mode, but debugger doesn't work anymore, which is strange, since I've not burned the eFuses.

       

      I've tried to download my original project, without any secure image, and it seems that programming works, but then none the program doesn't run as expected (it doesn't send anything on the serial interface) and the debug doesn't work anymore.

       

      Have I broken my board? If so, how is it possible if I've not burn the eFuses?

       

      Also when compiling again secure_image, I noticed this error:

      .\CortexM0p\ARM_GCC_541\Debug\secure_image.elf.tmp: openssl error:

       

      Can anyone help me? I don't have any idea of what is happening.

       

      Best regards