1 Reply Latest reply on Nov 20, 2018 2:42 AM by GeonaP_26

    Device does not start. Bootloader log attached. Can anybody decipher?

      Device works fine then all of a sudden the device does not start. The device get stuck in the bootloader and never starts the App.

       

      BLE OTA works with our own app and the CySmart app. We use i2c eeprom to store new program payload during an update.

       

      Anybody that can decipher the log from the bootloader?

      Are there any known bugs with this version of the bootloader?

       

       

       

       

      ===============================================================================

      =              BLE_OTA_External_Memory_Bootloader Application Started

      =              Version: 1.40

      =              Compile Date and Time : Jul 13 2016 16:37:13

      ===============================================================================

       

       

       

       

       

       

      CustomInterface:

      CyBtldrCommStart():

       

       

       

       

      BootloaderEmulator:

      CyBtldrCommRead():

      Metadata: Application Image Status: 0x000000FF

      Metadata: Image Size (in flash rows): 0x0000FFFF

      Metadata: Start of image in flash (row #): 0x0000FFFF

      Metadata: Application checksum: 0x0000FFFF

      Metadata: Encryption Enabled: 0x000000FF

       

       

      CustomInterface:

      CI_CalcExtMemAppChecksum():

       

       

      Calculated checksum: 0x00000000

       

       

      BootloaderEmulator:

      CyBtldrCommRead():

      Application Status in External Memory: UNKNOWN.

      Application status: INVALID.

      Halt Device.