1 Reply Latest reply on Nov 16, 2018 11:38 AM by MichaelF_56

    WICED 6.2.1 Mac installation

    user_3775416

      Hi everyone,

      right now I try to install Wiced on Macbook after used it on Window. The installation went well without error. However, when I run the app, it shows nothing on Project Manager. There are no platforms, demo apps, make target. I tried to import my projects on Window into the Project Manager, however, I can only import it in RemoteSystemsTempFiles which shows nothing in Project Managers.

        • 1. Re: WICED 6.2.1 Mac installation
          MichaelF_56

          Reinstall and make sure the executable and the eml file are in the same physical folder on your HDD.

           

          Also, make sure you follow the instructions below exactly:

           

          OSX Install:

          • Download the attached .zip file
          • Double click the zip file and extract all contents from the installer to a local folder
            • Note: When using the Safari Browser, it will automatically unzip the contents and create a folder
          • Note: the next two steps below are needed as a workaround for a known OSX 10.12 install issue called "App Translocation"
            1. Move the contents of the folder to another folder using ‘Finder’; Do not move the files using ‘Terminal’
              • Be sure to move the entire folder contents including the installer app file and config.eml.
            2. Run the command below using Terminal window:
              > xattr -r -d com.apple.quarantine <path>/WICED-Studio-X.X.X.X-IDE-Installer.app
          • See "Additional Installation Notes" below before installing
          • Double click the "WICED-Studio-X.X.X.X-IDE-Installer" app to execute the installer
          • After the installation in complete, launch the WICED Studio IDE from shortcut in the $HOME/Cypress $HOME/WICED/WICED-Studio-X folder

           

          OSX Uninstall:

          • From Finder, navigate to User > <name> -> Applications  -> Cypress and launch 'Uninstall'
          • To clean up all WICED components manually, delete files and folders for the IDE and SDK, typically in User -> <name> -> WICED/WICED-Studio-X and User -> <name> -> Documents -> WICED/WICED-Studio-X  or from terminal $HOME/Cypress/WICED*, $HOME/WICED/WICED-Studio-X and $HOME/Documents/WICED/WICED-Studio-X

           

          Additional Installation Notes:

           

          1.

          Open xterm, run the "java -version" command.  If it fails to return any results or states that you are running version 1.6, then you need to install the Java SE Development Kit 8, which can be found here: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html. Once the Java SE Development Kit 8 is installed, run the "java -version" command again with xterm.  If this command returns "1.6", then you will need to fix the symbolic link using the following commands:

          > rm -f /usr/bin/java

          > ln -s /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java /usr/bin/java

           

          2.

          Application downloads on WICED platforms may fail on certain OSX versions due to an incompatibility between the OSX version and the installed driver for the FTDI USB to serial chip.  On OSX versions 10.10 and earlier, a specific version of the FTDI driver must be installed using the instructions available here: https://learn.sparkfun.com/tutorials/how-to-install-ftdi-drivers/mac

          On OS X versions 10.11 and greater, the Apple version of the FTDI driver must be used, and any previous instance of the FTDI version of the driver must be removed from the system, by executing the following command in xterm:

          > sudo rm -rf /Library/Extensions/FTDIUSBSerialDriver.kext /System/Library/Extensions/FTDIUSBSerialDriver.kext

          Reboot the system after performing the rm command