3 Replies Latest reply on Nov 8, 2018 6:27 AM by vtunr

    Problem with arm gcc in WICED

    vtunr

      Hi,

       

      I have quite a big issue with arm gcc provided with WICED.

      When I try to build i have :

       

      arm-none-eabi-gcc.exe: error: CreateProcess: No such file or directory

       

      If I take one save i had from several month, it's working.

      From the non working, if I just extract a new SDK, it's still not working.

       

      I check a bit what arm gcc couldn't find and I found out that it was that it couldn't find other exe.

       

      Working :

      arm-none-eabi-gcc.exe -print-prog-name=cc1

      c:/users/xxx/43xxx_wi-fi/tools/arm_gnu/bin/win32/internal/cc1.exe

       

      Not working :

      arm-none-eabi-gcc.exe -print-prog-name=cc1

      cc1

       

      I dump config for both and it's exactly the same, I checked the path that it search on (with -print-search-dirs) and they also are the same.

       

      Also if I take one arm gcc i have for other project, I don't have a similar issue.

       

      SDK is share internally in my company through git, and if clone the repo in another computer I have the same issue.

       

      I tried replacing the whole ARM_GNU folder with the one working, same issue.

      Basically, if I don't use the save, it's not working.

       

      I'd like to understand what's wrong so I can fix this issue as i don't want to use an old save as once pushed on git, also have the issue.

       

      I really need some help for that.

       

      Regards,

       

      Tony

        • 1. Re: Problem with arm gcc in WICED
          rroy

          Hello Tony,

           

          I am not really sure about the fact what's wrong in your setup. I tested with WICED Studio 6.2.1 and checked -print-prog-name=cc1 and it was able to find cc1.exe which in my case was located at C:/Users/rroy/Documents/WICED-Studio-6.2.1/43xxx_Wi-Fi/tools/ARM_GNU/Win32/lib/gcc/arm-none-eabi/7.2.1. Could you check in your non-working setup do you have the cc1.exe is in your local FS?

           

          I have seen somewhat similar issue with mingw. I got the error removed in my WIN10 64 bit by adding <mingw install directory>\libexec\gcc\x86_64-w64-mingw32\<version_string> to the path. You can also try on similar lines with the location of cc1.exe

          1 of 1 people found this helpful
          • 2. Re: Problem with arm gcc in WICED
            vtunr

            Hi,

             

            cc1.exe is where it's supposed to be. I started from scratch from 6.2, applied all my patch, so now it's working on my machine. Pushed on git, clone from another computer => gcc error again.

             

            I really don't understand what's happening here. Any other lead on where the problem could come from ?

             

            Regards,

             

            Tony

            • 3. Re: Problem with arm gcc in WICED
              vtunr

              Just a quick update, i found what was the issue :

               

              Don't mkdir or clone the SDK from WSL (Windows Subsystem for Linux).

               

              Tony