5 Replies Latest reply on Oct 22, 2018 8:28 PM by yyca

    Cannot compile Denebola RDK firmware (SDK ver 1.3.3)

    omar.gonzalez_3749296

      HI

       

      I got Denebola RDK from e-con. Its working fine with default firmware, can see picture in Windows, Mac and Linux (Ubuntu 16). Now Im trying to modify the firmware to add support for external I2C sensor. I downloaded and installed Cypress "FX3 SDK ver 1.3.4"  for windows, after installation I opened e-con custom firmware and tried to compile to make sure everting was Ok, but I got the following error:

       

      I went back and loaded one of cypress firmware examples that came along with the installation, they compile successfully.

       

      Then I went and installed cypress SDK 1.3.4 in Mac and Linux and I got similar error (PATH variables configured correctly, following installation document):

       

       

      once again I tried compiling cypress sample code and it compiled successfully.

       

      I noticed e-con firmware is developed using FX3 SDK ver 1.3.3 and its calling different toolchain, I tried to download this older sdk installation on cypress site but they only have sample FW code for older SDKs not toolchain, there is a notice saying older code can be compiled with latest sdk toolchain.

       

      can you help me to figure out how to compile e-con sample FW using latest cypress SDK? or may be how to get older SDK toolchain?

       

      Thanks.