1 Reply Latest reply on Mar 5, 2015 4:38 PM by daveg

    WPS Enrollee does not connnect

    natwati

      The WPS enrollee feature of the WICED SDK is not working in my tests. I am running the snip.enrollee code from the unmodified SDK 3.1.2 on a BCM493362WCD4 without success. The demo.appliance is not connecting either using WPS.

       

      I tried out different Access Points and different WLAN channels:

      Firtz Box 7490

      Linksys E1000

      snip.wps_registrar on BCM493362WCD4

       

      Those Access Points all worked with a LG G2 mobile phone connecting using WPS Push Button execept for the snip.wps_registrar.

       

      Alll off the tests resulted in similar output on the UART:

      Starting WICED v3.1.2

      Platform BCM943362WCD4 initialised

      Started ThreadX v5.6

      Initialising NetX_Duo v5.7_sp1

      Creating Packet pools

      WWD SDIO interface initialised

      WLAN MAC Address : 44:39:C4:31:79:47

      WLAN Firmware    : wl0: Nov  7 2014 16:03:45 version 5.90.230.12 FWID 01-d095a660

      Starting WPS Enrollee in PBC mode. Press the WPS button on your AP now.

      Starting WPS Enrollee

      ...

      followed by this sequence

      ...

      Joining 'APPSDB_LSE1000_0001'

      WPS Procedure failed. Restarting with 80 seconds left

      ...

      or the following sequence or combinations of both

      ...

      Joining 'APPSDB_LSE1000_0001'

      Joining 'APPSDB_LSE1000_0001'

      ...

      WPS timed out

      WPS enrollment was not successful



      Here seems to be a similar problem:

      Using WPS to connect two WICED modules

       

      Is anybody able to run the snip successfull? What could cause the problems?