3 Replies Latest reply on Sep 29, 2018 6:47 PM by user_213748024

    about the CYUSB3014 booting problem

    user_213748024

      I have used CYUSB3014-BZX in my project, the device enumerated as "Cypress FX3 USB BootLoader Device" when the first time power on.

       

      Then I download img file to RAM.The control center shows programming successed.

       

      Usually, it should be reenumerated as a new device imidiated immediatly after that.

       

      But nothing happened in my application,the window stoped like this. 1.png

       

      Does any one have met this situation? And what should I do to solve this problem?

        • 1. Re: about the CYUSB3014 booting problem
          hman

          Hi,

           

          - The device to appear in the control center, it should have bound to cyusb3.sys driver.

          For the device to get bound to Cypress cyusb3 driver, the device should come up as Vendor class device.

          So, please let us know which firmware you have loaded?

           

          - If you have loaded any firmware which reports itself as standard class, for example video class, then you can see the device appears in the device manager under imaging devices section. (In this case it does not appear in control center)

           

          Regards,

          Hemanth

          • 2. Re: about the CYUSB3014 booting problem
            user_213748024

            I loaded the "slavefifo_examples" firmware in the FX3 SDK installation direction. I have tested this firmware in an other USB board, it worked properly.

             

            What confused me is why it appears as bootloader device first and disappear completly after I loaded the firmware? when it disappeared, it can not be found in device manager either, I mean compeletly disappear, even not appear as an unknown device, just like unplunged from the bus.

             

            I want to confirm whether it is a hardware issue or a configuaration issue? If it is a hardware issue, it should not work at all, the bootloader device should not appear in the control center. Am I right?

             

            When the bootloader device appears in the control center, can I think the IC is correctly powered on, the clock is ok and the CPU is ready to work?

            • 3. Re: about the CYUSB3014 booting problem
              user_213748024

              I think I have solved this problem.

               

              In my circuit, I put 2 ferrite bead in the 1.2V and 3.3V power line of the IC like this.

               

               

              The demo firmware can be loaded and reenumerated correctly after I shorted those 2 ferrite bead.

               

              I don't know if there were any other problem, but I can carry on now.

              1 of 1 people found this helpful