7 Replies Latest reply on Sep 16, 2018 10:40 PM by anks

    After changing to cyUSB.sys driver...

    rseedle_2385561

      After changing to the CyUSB.sys driver some wierd side effects seem to be occurring.

      1. In the Windows device manager, when I look at the driver, its name looks like:

         %VID_04b4&PID_1004.DeviceDesc%

       

      2. In USB Control Center I see a new entry:  KitBridge

      which looks nothing like the documentation in AN56377. The only way I can Identify it as the likely board is that

      the serial number matches. The PID is not what I was expecting. The configuration of the board does not match

      what was setup in AN56377. If I open USBview or Windows device manager and look at the PID, it is what I

      expected (ie. PID is 0003).

       

      3. The project in PSOC Creator 4.1 builds but the Debug -> Select Target and program

      shows zero valid targets even with "Show all targets" selected.

       

      Any ideas what I am doing wrong heard ?

        • 1. Re: After changing to cyUSB.sys driver...
          anks

          Have you made modification in  CyUSB.sys driver.

          Can you please provide the project in which you are observing the issue.

          Are you checking this on a Cypress development board or a Custom board

          • 2. Re: After changing to cyUSB.sys driver...
            rseedle_2385561

            I have not changed the CyUSB.sys .

            I will send you the project.

            I am using a CY8Ckit-059 PSOC 5LP prototyping kit which has a CY8C5888LT*-LP097 in it.

             

            Randy

            • 3. Re: After changing to cyUSB.sys driver...
              rseedle_2385561

              This is still an issue.

               

              Randy

              • 4. Re: After changing to cyUSB.sys driver...
                anks

                There are certain points for which I need clarification which as follows:

                 

                >>Firstly, are you able to program the  CY8CKIT-059 board , if you are not able to program then whose (means for which device ) VID and PID are you checking in Windows Manger

                 

                >>Secondly, if you are able to program the board with the code example, then accompanying this AN56377 application note are digitally signed drivers by Microsoft that have undergone WHQL testing

                You need not to change to cyusb.sys, you have mentioned "After changing to the CyUSB.sys driver ", so can you please mention how and why you changed.

                Please mention the OS version in your system too.

                • 5. Re: After changing to cyUSB.sys driver...
                  rseedle_2385561

                  Originally I was able to program the device when the board was set to

                  VID_04b4       PID_F139        The device driver at that time was KitProg.

                   

                  Then I changed the PID to PID_0003.

                  While still using the KitProg.sys device driver this seems to work OK. Then I changed the installed

                  device driver to CyUSB.sys to try to get access to the Cypress Suite USB 3.4.7 library.

                  From here on nothing has worked right. I tried changing the PID to 1004, no good. I tried changing the PID back to 0003, no good. Basically its a brick at the moment. The only thing I haven't tried to go back to the KitProg driver.

                   

                  The source code of the CyUSB.sys driver has NOT been rebuilt/changed in any way.

                   

                  Randy

                  • 6. Re: After changing to cyUSB.sys driver...
                    rseedle_2385561

                    I am using Windows 7 64 bit OS. Before this current problem, while still using KitProg I was unable to see the complete configuration that was programmed into the board. Is there a newer version of the KitProg device driver that I should be using ?

                    • 7. Re: After changing to cyUSB.sys driver...
                      anks

                      I tried programming and checking enumeration of all three projects of AN56377 using  CY8CKIT-059 on Windows7. They all get enumerated as "USB-Serial Composite device " and "USB serial Port"

                      I didn't needed to change the driver or update the driver as this AN56377 application note  already has  digitally signed drivers by Microsoft that have undergone WHQL testing.

                       

                      I am attaching the screenshots too.

                      None of projects needs Kitprog.sys for the device enumeration. Kitprog.sys is needed for Kitprog's enumeration which works  as Programmer/Debugger.

                       

                      You can get the  Kitprog's driver or program its hex which are available at this path in your system:

                      C:\Program Files (x86)\Cypress\Programmer\drivers\KitProg

                      C:\Program Files (x86)\Cypress\Programmer

                       

                      What you need to do is  after programming  the CY8CKIT-059 kit using Kitprog is that  connect the Micro USB connector present at other end of CY8CKIT-059 available as PSoC5LP USB to the PC's USB port, then you will get these project's enumeration correctly done as expected.