1 Reply Latest reply on Sep 2, 2018 11:35 AM by ryan_3612081

    Unable to Open Connection to COM

    ryan_3612081

      I using the PSoc 6 Pioneer kit to go through the PSoC 101 video series. I'm on lesson 2-1 and have hit a snag trying to communicate with the device over the UART.

      The device seems to program up fine with the example UART code, but I have no way to test it because I cannot connect to the serial port of the device from PuTTY or any other terminal.

       

      I have installed PSoC Creator on two different computers both running Windows 10.

      The device shows up on both in the Device Manager under 'Ports (COM & LPT)' and driver says it is Cypress v.2.0.0.2

      I have tried connecting to the port with both computers from PuTTY and both computers give the same error:

      "Unable to open connection to COM4

      Unable to configure serial port"

       

      This Thread describes apparently the same error:

      UART port can't be accessed

      But the fix there that is the accepted solution is simply to restart the computer, which does not work in our case.

       

      Also: I've run the update manager to see if there was a new driver. But still no luck.

      And: Other serial devices are working fine in the terminal. Whatever is going on is specific to the PSoC 6 kit.

       

      Anyone having similar issues?

      Thanks,

      R

        • 1. Re: Unable to Open Connection to COM
          ryan_3612081

          Ok, it's sending data to the termial now- Silly beginner's mistake

          I didn't know that it was necessary to hit the 'Mode Select' button to get the KitProg2 device in the correct mode for USB-UART communication. But now I do.

           

          I still don't have getchar(); working yet, but I think the COM port issues are resolved

          Thanks!

          1 of 1 people found this helpful