1 Reply Latest reply on Sep 2, 2018 10:21 PM by rroy

    OpenOCD failed - ensure you have install

    bhavna.harani_3569606

      Hello,

       

      I have tried to download the program using olimex debugger.

      It is working good in wicedSDK 3.7,but when I have moved my application from 3.7 to 6.2 latest sdk ,it is not working.

      below error message showing.

      ********************************************************************************************************************************

      Downloading Bootloader ...

      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

      Downloading DCT ...

      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

      Downloading Application ...

      "**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****"

      Resetting target

      make.exe[1]: *** [run] Error 1

      tools/makefiles/standard_platform_targets.mk:205: recipe for target 'run' failed

      make: *** [main_app] Error 2

      Makefile:351: recipe for target 'main_app' failed

       

       

      12:14:34 Build Finished (took 30s.930ms)

       

      ********************************************************************

      In device manager ,I can see the olimex debugger still showing above error.

       

      I have attached openocd_log.txt file for both wiced IDE.(3.7 and 6.2).(for  wiced IDE 3.7 it is working fine.)

       

      5kb file for wiced IDE 6.2

      63kb file for wiced IDE 63kb

       

      Please help me regarding this.

      Your help will be appreciated.

       

      Message was edited by: Bhavna Harani

        • 1. Re: OpenOCD failed - ensure you have install
          rroy

          I don't see any WICED device in your device manager window (is COM4 your WICED platform?). Are you able to program your platform directly through the normal WICED download process or you are not even being able to do that?

           

          Please let us know if you are using any Cypress EVB and the make target that you are using. I am assuming that you have gone through 43xxx_Wi-Fi/tools/OpenOCD/Olimex_README.txt as it was working in an earlier SDK; if not please go through the same.

          1 of 1 people found this helpful