5 Replies Latest reply on Feb 9, 2015 9:12 PM by userc_14749

    A problem about "Download failed"

      Hi all !

      I buy a Wiced Sense Tag , just this one .20150203_163052.jpg

      I download the SDK 2.2 ,install the drivers, like this123.JPG

      I start IDE and try to downlaod one target to the device,but none of the targets is ok ,always like this:

       

      Detecting device...

      +------------------------------------------------------------------------------------------+

      | No BCM20737 detected                                                                     |

      | 1. Verify the BCM20737 tag is connected _AND_ powered                                    |

      | 2. Verify SW2 and SW3 switches are towards Vusb and Vreg respectively and all SW4        |

      |     switches are set to ON                                                               |

      | 3. Press the reset button on the tag and retry                                           |

      |                                                                                          |

      | If this problem persists, the EEPROM on the tag may be corrupted                         |

      | Please see Appendix D in the Quick Start Guide for recovery instructions                 |

      +------------------------------------------------------------------------------------------+

      Download failed. This version of the SDK only supports download to BCM20736A1 and BCM20737A1 devices

      I don't what to do with this.The battery is put in ,and is powered.I don't  know where to find SW3 or SW4 .

      I really need some help , thanks!

        • 1. Re: A problem about "Download failed"
          MichaelF_56

          These devices were designed to be evaluation boards only, so when they power up, they are in application mode.

           

          What many have figured out is that in addition to only using them for evaluation purposes, they can also be programmed as well.

           

          Go here: WICED Sense Table of Contents

           

          And look for the link to the recovery procedure.

           

          There are two methods to reset the kit, but the only one I found that works consistently is to carefully crack the case open and press the reset button inside.

           

          This will put the device into programming mode.

          • 2. Re: A problem about "Download failed"

            Thanks for your kind reply !

            I tried to download the whole afternon ,There was only on time successfull,I download  "hello_sensor-

            BCM920736TAG_Q32 download" to the tag.Then I found that my phone cannot connect to the tag . I tried to download

            again ,it always failed again.I just don't why....

            After I read your reply , I did crack the case open, I pressed the reset button inside whith battery,but it did not

            work.I just feel down deeply...I am new in this area.I will try it again tomorrow and hope it work.
            Thanks very much!

            • 3. Re: A problem about "Download failed"

              I am not sure about windows development, I do uploading from linux environment and the trick is to specify the UART port from the download.

               

              the command i use to download is

               

              sudo ./make wiced_sense-BCM920737TAG_Q32 UART=/dev/ttyUSB0 download

              1 of 1 people found this helpful
              • 4. Re: A problem about "Download failed"

                what I’ve noticed is that if you follow these steps:

                • - Insert battery in WICED sense
                • - Immediately insert USB cable
                • - Attempt to download firmware via either “q2.bat” programming script or from within SDK

                … the firmware downloads successfully.

                 

                If I then attempt to do it again without power cycling the SENSE board (battery removal) the firmware download will fail.

                 

                Note that when I do this from a fresh battery-insertion, the SENSE board is actually running prior to the firmware download: you can see the LED / PWM do its thing.

                 

                How is this behavior explained?  If the application is running, even from a fresh power-on-reset, I would think any attempt at a firmware download would fail, correct?

                 

                The SENSE board has a pulldown on UART_RX (R6) which (presumably) puts the part into application mode upon a power-on reset.  Doesn't the module itself have an internal pulldown on UART_RX already, making this R6 redundant and unnecessary?

                • 5. Re: A problem about "Download failed"

                  Hi andrew997,

                   

                  I do discover similar behavior. However, my uploading process is way easier, just take the battery out, connect USB and run the upload command.

                   

                  The program would run after the download, and at this point, you will not be able to download anything, it would ask you to reset. And the odd thing is even though the device could run from the USB power, but once it is put into the sleeping mode, none of the buttons would be able to wake it up from the sleep. Only putting the battery in would actually wake it up again.