3 Replies Latest reply on Sep 7, 2018 7:40 AM by will_2253191

    Attach to Running Target - no targets

    will_2253191

      I am trying to debug my project, which uses Bootloadable/Bootloader.  This has been working fine for about a year.

       

      When Bootloadable is disabled, I can program the chip and then "Attach to running target" with no problems, so I don't think this is a hardware problem.

      When I enable Bootloadable, program, and then try "Attach to running target", no targets are displayed.

       

      "Enable Device Protection" is disabled in the application code and the bootloader.

       

      Any ideas about what could have changed?

       

      Thanks.

        • 1. Re: Attach to Running Target - no targets
          GeonaM_26

          Ensure that SWD interface is enabled in the project as Debug Select to SWD in the .cydwr window.

           

          Reduce the path size, preferrably unzipping the workspace archive in Desktop.

           

          If it does not help, please share the project and PSoC Creator version to recreate the issue at our end.

          • 2. Re: Attach to Running Target - no targets
            will_2253191

            Hello Geon,

             

            Yes, Debug Select is set to SWD.

            The project is in c:\projects, so the path can't get much shorter.

            I am using the latest version of PSoC Creator (4.2.0.641) on Windows 7.

            How can I share my project privately with Cypress Support?

             

            Thanks,

            -Will

            • 3. Re: Attach to Running Target - no targets
              will_2253191

              Thanks to FAE Kevin Reed for solving this.

               

              Performing "Clean and Build All Projects" solved the problem.

               

              The issue was caused by the .hex file for the Bootloader project not getting updated.  Although I had done a "Clean and Build [MyMainProject]", and "Build All Projects", the Bootloader project had previously been compiled with Code Protection enabled and the .hex output still contained this setting, which prevented the main project from being debuggable (hence, did not show in list of targets).