1 Reply Latest reply on Aug 10, 2018 1:28 AM by SayaniS_66

    Erros on updating PSoC Creator components

    user_1477726

      I get Error 500 : Internal server errors when I update PSoC Creator and other associated programs like PSoC Programmer.

       

      I read the other threads created about a month ago on the issue where it states that you have to go to the download pages and get the latest version of the software. I have done so, but is is not the latest versions. If I start Update Manager, It finds later versions, but fail to install them due to the above error.

       

      When will this be fixed?

       

      I have a problem where there is a discrepancy between the device ID's found when programming from PSoC Creator versus programming through PSoC Programmer. I am developing on a CY8CKIT-062 using the CY8C6347BZI-BLD43 chip and I program the device perfectly using the built-in programmer. This however also erases the emulated EEPROM when I reprogram the device. When I try to use the PSoC Programmer software in order to prevent the erasure of the WFlash, it detects the device as a CY8C6347BZI-BLD54 and as  result it will not program.

       

      I cannot update the Programmer software in the hope that it will fix the issue as the update fails and  the PSoC Creator bundle apparently does not contain the latest version, although the version indicated in the update manager shows the same version as the version I have, but it still shows there is an update available. The release note link on the Update manager also returns an error 500 : internal server error so I cannot see if any fixes were done to it.

       

      What am I to do?

       

      Regards

      Chris