1 Reply Latest reply on Aug 5, 2018 2:59 AM by bob.marlowe

    Bootloadabler app not writing full flash memory

    ricardoluna274_3624676

      Hi, I'm starting to learn the PSoC hardware, I'm using the LED blinking + UART bootloader examples code for the CY8CKIT-049-41xx board kit Setup File package . I'm able to change the PWM parameters of the LED blinking application that runs when not pressing the button, build and use the bootloader host to download the firmware to the board, confirmed by the different times the led is on and off. However I've tried to change the PWM parameters of the faster LED blinking in the UART Bootloader side, rebuilding all the files and then downloading the firmware again but no matter the changes I do, it appears the bootloader host is only rewriting the LED blinking side, since the LED time of the Bootloader app remains always the same. It is my guess that the bootloader app is only writing the memory blocks of the LED Blinking app, but not it's own section. It was my understanding that the boot loader host sent the full memory contents to the bootloader app and reflash the full memory, is this suposition correct? How could I perform any other changes to the bootloader app in that case? What if I wanted to change it to communicate by I2C then? That's why so far I've only tried the led time change, in case something else fails. Also, when I used the example code for the first time, the compiling failed saying the bootloader components were a previous version (1.3). I used project->update components to repair it (version1.6) and it built successfully. Then I had the issue mentioned above. Not sure if it could be related but worth mentioning. I'm attaching the workspace files as suggested by user_242978793 in a similar post. Thanks a lot for cheking it!