5 Replies Latest reply on Jul 25, 2018 5:33 AM by rroy

    How to install WICED Studio on Mac

    weston.spalding_3539371

      I am having issues installing WICED Studio on my Mac. I have followed the extra steps outlined here: WICED-Studio-6.2.1 (OSX) . Everything seems to go normally but once the installer has completed and I try to open the application I receive a warning: Screen Shot 2018-07-09 at 8.54.20 AM.png

      I have attached the log file but an excerpt is shown below.

       

      `

      !ENTRY org.eclipse.cdt.autotools.core 4 0 2018-07-09 08:46:30.336

      !MESSAGE FrameworkEvent ERROR

      !STACK 0

      org.osgi.framework.BundleException: Could not resolve module: org.eclipse.cdt.autotools.core [43]

        Unresolved requirement: Require-Bundle: org.eclipse.cdt.managedbuilder.core; bundle-version="5.0.100"

          -> Bundle-SymbolicName: org.eclipse.cdt.managedbuilder.core; bundle-version="8.3.0.201502131403"; singleton:="true"

             org.eclipse.cdt.managedbuilder.core [78]

               Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.0.0,6.0.0)"

                 -> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version="5.9.1.201502131403"; singleton:="true"

                    org.eclipse.cdt.core [53]

                      Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

       

       

      at org.eclipse.osgi.container.Module.start(Module.java:434)

      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)

      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)

      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)

      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)

      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)

      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

      `

       

      My guess is it was a Java version mismatch, but I've since tried with Java versions 9, 8, and 7 with the exact same result. The macOS version I am using is 10.12.6.

      I've tried version 6.2.1 and 6.1.0 again with the same results. I'm kind of at a loss of what to try next.