7 Replies Latest reply on Jul 19, 2018 9:22 PM by jyamaha_3554436

    GPIF II Designer Does Not Load In Windows 10

    jyamaha_3554436

      I have two machines - one that is out of space (a disk limited machine with no internal upgrade potential - Windows tablet class device) and a powerful "unlimited" resource workstation.   The limited machine has the latest FX3 SDK installed - and GPIF II Designer works fine.   The "unlimited" machine has a fresh install of the FX3 SDK and the GPIF II Designer does not load.  Unfortunately, debug and development on the weaker of these two machines is not a viable option - I need to get my workstation happy with GPIF II Designer and the rest of the suite.  I'm not sure what works and what does not as of yet - the GPIF II Designer is my first step in development.

       

      Here's a rundown of what I have tried:

       

      1) Reinstall of GPIF II Designer by uninstalling and reinstalling using the .msi in the SDK's "updates" folder.

      2) Tried above as administrator

      3) Tried reinstalling the .NET 3.5 requirement.  My limited machine did not have this package installed - so I installed it as part of the SDK installation.  The workstation already had .NET 3.5 installed along with many other versions.  The .exe for installing .NET 3.5 from Microsoft bails out - presumably because .NET 3.5 is already installed (which it is).

      4) Tried repairing the SDK a few times (entire - not just the GPIF II Designer portion)

      5) Tried launching GPIF II Designer as my normal user - and by forcing administrator

      6) Tried running GPIF II Designer in each of the available compatibility modes from Vista on to Win 8.1 and all between

      7) Tried the sfc thing - no problems found (except the time it took to get there -- translation: "waste of time").

      8) Did the "search-engine thing" to try to find something close enough to attack the issue.  Found some things.  Tried some things.  Nothing either really applied or worked.  One interesting post was about local policy changes and disabling crypto policies.  I checked that - already disabled (so didn't apply) - but it is interesting in how it may relate to the next bullet (maybe)

      9) I had a yellow bang on TPM in Windows (the Windows Defender Security Center taskbar icon).  It was out of date because my PC manufacturer doesn't want to cram TPM updates that may mess with drive encryption software and render your HDD a brick.  This is related to Infineon TPM modules and a security flaw which could make it possible to unlock somehow.  This couldn't have been the issue - but I tried enough things - why not?  I updated TPM to the latest version just to get rid of the yellow bang.  Yellow bang gone -- GPIF Designer II still not working.

      ...

      1,000,000) Probably enough other things so I can say I've tried a million things.

       

      The two machines are different architectures - both x64 - but the workstation is a Xeon while the limited machine is standard issue (Intel).  I do not think this is an interesting difference - so I'm not providing the gory details.

       

      Here is the event log error when I try to launch GPIF II Designer (aka C:\Program Files (x86)\Cypress\GPIFII Designer\bin\cygraphicaltool.exe)

       

      ----------- snip -----------

       

      Fault bucket 2146149135865279118, type 5

      Event Name: CLR20r3

      Response: Not available

      Cab Id: 0

       

       

      Problem signature:

      P1: cygraphicaltool.exe

      P2: 1.0.1198.2

      P3: 54940ad4

      P4: PresentationCore

      P5: 3.0.0.0

      P6: 5a7d2bb4

      P7: 5028

      P8: 0

      P9: System.TypeInitialization

      P10:

       

       

      Attached files:

      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER224A.tmp.WERInternalMetadata.xml

      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2289.tmp.xml

      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER22B7.tmp.csv

      \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER22C8.tmp.txt

       

       

      These files may be available here:

      C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_cygraphicaltool._46ede52786cec59c289588f1fffe6a2a232ca_00000000_3b162641

       

       

      Analysis symbol:

      Rechecking for solution: 0

      Report Id: 00b37e08-8e46-4ea1-a7c0-ea41053d2be9

      Report Status: 268435456

      Hashed bucket: 248d9d33a9d61beaadc8a744ae42f28e

      Cab Guid: 0

       

      ---------- snip ------------

       

      Feel free to suggest another few ideas to throw on the fire.  I'm not going to reinstall Windows.  I can reinstall the SDK again just to do it.  That's likely to be the first suggestion. 

       

      Thanks in advance for the community's help.