2 Replies Latest reply on Jun 26, 2018 5:38 AM by jtobin_3265626

    Issues installing KitProg USBUART drivers

    jtobin_3265626

      I recently started playing around with a couple of CY8CKIT-059s for a project that I'm working on. Unfortunately, I'm not able to get the USBUART drivers to install. I've tried:

       

      1) Plugging the dev board into 4 different Windows 7 64bit PCs.Windows looks for the driver but eventually gives me an error and says that it can't find drivers for the device.

      2) Uninstalling the device via the device manager, rebooting, and repeating step 1. This gives the same result.

      3) Uninstalling the device via the device manager, downloading the Cypress USB-Serial installer from here and installing the drivers. The device still doesn't work and Windows doesn't see drivers for it.

      4) Under the folder where the Cypress drivers were installed, running CyDriverInstaller_x64.exe. This briefly brings up the command prompt and says "Please rerun the driver installation setup for driver repair operation." I've tried both a) running CyDriverUninstaller_x64.exe and then rerunning the installer, and b) removing everything from the USB Serial Driver folder using their uninstaller, reinstalling the driver package, then reinstalling the 64 bit driver. Regardless, I still get the message telling me to rerun the installation setup for repair.

       

      All the installers have been run as an administrator, and when I reinstalled the driver package, I made sure to do so outside of the Program Files folder.

       

      Does anybody have any recommendations or ideas as to how to get these drivers installed and running correctly?