8 Replies Latest reply on Jun 25, 2018 12:25 AM by user_108962310

    BT LE Continuous Transmit Test with bt_mfg_test, no observed tone output

    user_108962310

      I am having an issue with running bt_mfg_test on a 4343W radio.
      I can build and flash the `bt_mfg_test` project, and invoke the control commands, but I cannot get the `set_tx_frequency_arm` mode to work.

       

      For example, the `le_transmitter_test` does work, and I see "Received HCI event" at the command line, and I can see output on a spectrum analyzer.

      Same for the simple commands, like `reset`.
      But: when I run the `set_tx_frequency_arm` command, I the mbt.exe tool just returns without reporting even "Sending HCI command".

       

      Note: I did have to make a patch to the BT mfg_test library to get the application to start correctly:

      In bt_firmware_download, There is the code:

      /* TODO : Eventually we will be using the patchram_download_baudrate variable from the platform file. */

      /* update BT and host to switch to 3mbps */

      if ( bt_host_update_baudrate( BAUDRATE_3MPBS ) == WICED_BT_SUCCESS )

      {

          fast_download = WICED_TRUE;

      }

       

      I made this change because I was observing a breakpoint on failure to load BT firmware. Commenting that baud rate change out (and leaving it at 115200) solved that error.