2 Replies Latest reply on Jun 12, 2018 12:39 PM by user_455868498

    Building Bootloader fails in WICED 6.2 for my configuration

    user_455868498

      I'm having difficulty being able to use WICED 6.2 - it fails to build.

      Any ideas I can try to narrow down the issue would be appreciated.

       

      I've narrowed the issue down to the simplest Make Target, snip.scan, which works on WICED 6.1 and fails on WICED 6.2 for me.

       

      Following is the error when running a Make Target that comes already setup = snip.scan-BCM943362WCD4

       

      20:44:22 **** Build of configuration Default for project 43xxx_Wi-Fi ****

      "C:\\Users\\a73744\\Documents\\WICED-Studio-6.2\\43xxx_Wi-Fi\\make.exe" snip.scan-BCM943362WCD4

      MAKEFILE MAKECMDGOALS=snip.scan-BCM943362WCD4 OTA2_SUPPORT is disabled

      Building Bootloader

      c:/users/a73744/documents/wiced-studio-6.2/43xxx_wi-fi/tools/arm_gnu/win32/bin/../lib/gcc/arm-none-eabi/7.2.1/../../../../arm-none-eabi/bin/ld.exe: cannot find @C:\Windows\ccCjvoqt: Invalid argument

      tools/makefiles/standard_platform_targets.mk:90: recipe for target 'bootloader' failed

      Makefile:351: recipe for target 'main_app' failed

      collect2.exe: error: ld returned 1 exit status

      make.exe[3]: *** [build/waf.bootloader-NoOS-BCM943362WCD4/binary/waf.bootloader-NoOS-BCM943362WCD4.elf] Error 1

      make.exe[2]: *** [main_app] Error 2

      make.exe[1]: *** [bootloader] Error 2

      make: *** [main_app] Error 2

       

      20:44:23 Build Finished (took 1s.30ms)

       

      I'm running Windows 7 Professional, Service Pack 1

      Intel Core i7-6600U @ 2.6GHz, 8GB RAM

      MS Outlook is the only other program running

       

      I tried uninstalling and re-installing WICED 6.2 several times.

      I also uninstalled all other versions of WICED then reinstalled WICED 6.1

      I have been running projects using WICED 6.1 and previously WICED 5.2 without issue.

       

        • 1. Re: Building Bootloader fails in WICED 6.2 for my configuration
          zhez

          Hi  user_455868498

           

              after you install 6.2 sdk , do you have a check about if there missed some files compare to 6.1 install?

          I used to meet the problems which has no any source code in the directory ,   often re-install to solve the issue.

          and if all source code and directory are correct installed and extracted ,  All I can think is we upgrade the GNU tools in 6.2 release,

          assume there has a compatible issue with your environment,  just for a try Can you copy the old gnu to the 6.2 for a try ?

          1 of 1 people found this helpful
          • 2. Re: Building Bootloader fails in WICED 6.2 for my configuration
            user_455868498

            zhez,

            Thank you for the suggestion to check GNU.

            I tried to look for the GNU files, but Microsoft's File Explorer wouldn't let me search. I realized then something was wrong with the core programs on my PC. That made me think a similar issue may be happening with WICED. I’m not clear why the issue only occurred with WICED 6.2.

             

            Key things done to my computer that now allow WICED to work include:

            1. Updated BIOS - An updated BIOS is most likely what fixed my issues with WICED 6.2
            2. Re-Indexed by entire drive - Indexing has been running for 6 hours – not done yet. It seems to run faster if I’m not using the computer. There's a chance WICED 6.2 couldn't find the GNU files it needed due to the drive being incorrectly indexed.

            Thank you again for your suggestions. WICED 6.2 is now working flawlessly!

            1 of 1 people found this helpful