3 Replies Latest reply on Jun 12, 2018 8:54 AM by jonathanlui_3455101

    How to resolve the build error "lto_wrapper failed" in PSoc Creator 4.2?

    jonathanlui_3455101

      Hi,

       

      I am building the "CYPD3125-40LQXI_notebook" sample project from the "CCGx EZ-PD SDK 3.0.2" package in PSoC Creator 4.2 with no modifications of my own. The build error: "lto-wrapper failed" keeps appearing.

       

      After some googling, I found that this is a known issue after PSoC Creator was updated to a newer version, but no one posted a solution besides the suggestion of renaming cm0gcc_*.ld to cm0g_*.ld, which didn't work for me. I also tried deleting all the *.o object files and do a clean build, but same error comes up. I already updated the components in the sample project.

       

      Does anyone know a solution? This is my first project in PSoC Creator.

       

      Thanks,

      Jon