1 Reply Latest reply on Jun 11, 2018 12:01 AM by sujayy_46

    Low power mode question in cyw920719

    NiLi_2861801

      Hi, 

           The sample WICED-Studio-6.2-SDK\common\apps\demo\low_power_sensor,  10s timer will lead the board into SDS mode.  I connect a Ammeter  between PIN2 & PIN4 at jumper J8 and detect current = 0mA while SDS mode. When I press the button(SW3), or connect A5(WICED_P17) to 3.3V,  the board will go a WARM BOOT.

            Then, base on this sample, I modified the file low_power_mode.c (attachment file).  The Ammeter display 0.04mA. and button or P17 will just output a string displaying the event happend, not a boot flow. It seems that the board did not go into SDS.  What did I miss for the sleep configure or other things?

            (What I modified are: delete all the codes about bluetooth, just left the 10S timer and sleep configuration.)

            here are the output:

       

      [2018-06-11_14:32:28]sleep_mode=0

      [2018-06-11_14:32:28]Hello Sensor cold Start

      [2018-06-11_14:32:28]hello_sensor_application_init

      [2018-06-11_14:32:28]idle timer start successful

      [2018-06-11_14:32:28]......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................hello sensor idle.   

      [2018-06-11_14:32:38].$.$.@.$.$.@.$.$.@

      [2018-06-11_14:35:28].$.$.@hello_sensor_interrupt_handler

      [2018-06-11_14:35:34].$.$.@

       

      red line display a button press event.

        • 1. Re: Low power mode question in cyw920719

          It is necessary to initialize the stack for the device to enter SDS. If the stack is not initialized, the device enters PDS and not SDS.

          So, just add a wiced_bt_stack_init in your application and move the call to hello_sensor_application_init() to BTM_ENABLED_EVT in the management callback. That should solve your problem.

          1 of 1 people found this helpful