2 Replies Latest reply on Aug 30, 2018 3:54 AM by zhouyaming_2401356

    FX3 SDK 1.3.4 issue with using interrupt endpoint to respond to UVC control requests

    stjepan.henc_1547166

      Hi,

       

      I am working on maintenance of my companies FX3-based UVC camera.

       

      I installed FX3 SDK 1.3.4 today, the first update after a couple of years.

      I noticed there were a couple of changes, new installer, much faster compile time, and that J-link support was changed a bit.

      I got JTAG working, recompiled the firmware and managed to run it on the hardware.

       

      I have some code that handles UVC control requests (a type of Setup requests over Ep0),

      and for some controls it cannot meet the 10 ms deadline for UVC control request responses so the response is sent over the Interrupt endpoint (over a DMA channel allocated for this purpose).

      When compiled with FX3 SDK 1.3.4 the interrupt endpoint start responding very slowly and with delays.

       

      Recompiling it with FX3 SDK 1.3.3 makes the bug go away.

       

      I don't remember reading anything in the release notes that might indicate something changing in the USB drivers that would cause this.

      Or might it be related to the changed compiler version?

       

      I since moved back to using FX3 SDK 1.3.3 since I have deadlines, just letting you know that there seem to be some issues with this release,

      in case someone else runs into a similar problem.

       

      I am not sure changing so much stuff was a good idea for a mature product.

       

      Best regards,

      Stjepan Henc