13 Replies Latest reply on Feb 5, 2019 3:39 PM by LuGi_2890336

    Download failed CYBT-343026-EVAL

    LuGi_2890336

      I'm developing an application with CYBT-343026-EVAL. Since two days it's impossible to program the module and the WICED Studio print in console the following message:

       

      Downloading application...

      ********* Download Failure *************

      +-----------------------------------------------------------------------------------------------+

      | Follow below suggestions and retry. |

      |   1. Verify USB-UART driver is correctly installed |

      |   2. Verify SW4 switches are in ON position (CTS, RTS, RXD, TXD) |

      |   3. Power cycle CYBT-343026-EVAL and retry. |

      | |

      | If this problem persists, the serial flash on the board may be corrupted. |

      | Follow below steps to reset CYBT-343026-EVAL board to factory default state.                |

      | Note: This will erase any user applicaiton in the memory and reset the board to dafulat state |

      |   1. Press and hold RECOVER button (SW2) |

      |   2. Press and hold RESET button (SW1) for 1 second |

      |   3. Release SW1 |

      |   4. Release SW2 |

      |   5. Re-program the board |

      +-----------------------------------------------------------------------------------------------+

      Download failed. This WICED platform of the SDK only supports download to 20706A2 device.

       

       

      10:57:27 Build Finished (took 1m:27s.577ms)

       

      I have followed all the seggestions and all the indeications in the guides and in the forum posts but nothing change. tried also to change J8 but without effect.

      Only one time I was able to program it but then never again.

       

      I have noticed that the RTS and CTS signal (by J1 connector) are alwais low for all the comunication until it fails. Is it right?

       

      The drivers seem installed correctly, I can see two common "USB Serial Port" but I'm not sure they are correct because, if I'm not mistaken, it should be WICED HCI UART. I have tried to install the driver inside WICED Studio path but windows do not install it correctly. My OS is Windows 10.

       

       

      Where could be the problem?